Aqara Wall Switch NOT working in Decoupled Mode

Is here anyone who’s got the Aqara Wall Switch working in Decoupled Mode? Specifically this model Aqara H1 EU Wall Switch (With Neutral, Double Rocker) WS-EUK04 Zigbee compatibility but I’m sure other similar models (one rocker, three rockers) should work (or NOT work) too.

I found some topics here on a forum indicating this switch should work but I cannot confirm that. Maybe they had a different version (no neutral?) but specifically this version of the switch is NOT working in decoupled mode in zigbee2mqtt. Pressing buttons simply don’t generate any kind of activity. I checked MQTT logs (in Zigbee2MQTT addon) and it does nothing so you have no means whatsoever how to tell any button was pressed.

I post it as a warning to others who want to buy this switch and use it in decoupled mode (as I wanted :frowning: )

3 Likes

Seeing the same issue.

I also seeing the same issue.

Very frustrated as I thought this is / was my dream switch. I’ve been looking for this for ages and decoupled mode sounded perfect. This is surely an implementation issue rather than a switch issue, as I can’t see the point in having a decoupled mode and then having the switches do nothing or not send Zigbee messages.

Is anyone able to shed any light on this or offer any advice? The device is listed as supported.

Thanks.

Same for me, using mosquito broker, zigbee2mqtt. Tried also in zha without access to decoupled mode. HA can trigger actions in the switch but actions in the switch do not get seen by HA leading to their being out of sync. Notably also the power consumption fails when I try to refresh it in zigbee2mqtt. Have load on both L1 and L2 ( though with neutral, this shouldn’t be required.

All other devices work fine, so don’t think the core set-ip is wrong.

Also tried exposing it to hass using aqara hub. If relay is on, button presses do reach hass. Relay off, no events or anything reaches hass.

I’m getting this with the D1 version too, I sent the decouple command via MQTT integration topic but it doesn’t fire any action for a decoupled button press.

I also set “state_action: true” in the /share/zigbee2mqtt/devices.yaml as described here Xiaomi WS-EUK04 control via MQTT | Zigbee2MQTT, but no difference.

any updates on this, like youn all i bought these switchs for the whole reason of being able to decouple and som my smart bulbs where poered all the time. also if there was a power cut they can be put into relay mode by holding the left button. I payed out a lot of money to replace my moes switchs which done the job as i bypassed the switch so my bulbs were permantly on and controll was dont by the switchs and automations. What is the point of decoupled mode if the switchs do nothing. im hoping ive missed something obviouse.lol

No update really… I tried a single button model, same problem.
I messed the set-up of mosquito broker and zb2mqtt and the mqtt integration to make sure they all used my mqtt-user. No change.
I remain convinced it is an implementation problem, not a hardware problem, as I’ve seen on various YouTubers videos showing the power usage and actions with single and double presses.
Just run out of helpful set-up guides

I just managed to get this to work - but it involved flashing the firmware of my CC2531.

Previously I was on version 20190608 and I flashed it to the latest 20211115 and this all just started working!

I wasn’t aware that the device firmware was a possible reason this wasn’t working. Another side effect is the power monitoring and temperature monitoring features of the switch started working.

after flashing your dongle you need to remove the broken switches and add them again. Also, when flashing i’d recommend the video on youtube that shows you how to enable bootloader mode. Good luck, wasted a lot of time beforeni thought to delete and add again!

I’ve been happily using the Aqara WS-EUK03 single button with Neutral for around a year or more in decoupled mode, using the action of single press to toggle a shelly dimmer module controlling my ceiling lights.

I’ve setup WLED to the room, so bought the WS-EUK04 to replace my existing switch, so that I can use both left and right buttons in decoupled mode, one for my ceiling lights, one for WLED.

I figured it would be a straight swap, just wiring up as before and only using L1 wired to the dimmer as before. Although the new switch works in relay mode, to control my dimmer that it is wired to, when i try to use decoupled mode, neither side is reporting any button click actions to HA. I came across this thread, and some Github posts about it, but the only answers I could find relate to updating firmware/zstack. I’m using the Sonoff ZB Bridge, running Tasmota 13.1.0. This handled the single button click in decoupled mode fine on my WS-EUK03.

Can anyone suggest how I can get this working?

Ahhh! Darn just gone down the same rabbit hole. Brought a couple of the WS-EUK02 models. All works fine in HA but cant decouple them! get an error when I try. Sounds like I’d be wasting my time anyway! For me it’s no big problem if the relay is trigged as a duel switch one is physically connected to ceiling light the other is unconnected and just used a trigger to a smart plug for a bedside lamp. I have the M2 Hub as well to experiment with. So may have to use that and the Aqara cloud anyone know if decoupled mode works that way?

PS: This may have been picked by others but on the duel models say L1 = Left and L2= Right. You would assume that is as you look at when mounted on the wall! Nope! Its as you look from the rear when wiring up. So swap them round if you want if correct when looking from the front

Hulo, first post here, but thought it was worth chiming in…

We’ve just had our whole house completely refurbished and I decided, perhaps foolishly, to go all in on HA without ever having used it. I also very much wanted to do both smart bulbs and smart switches… it’s such an obviously useful combo that I can’t believe it’s not more common. As such I just went straight ahead and had the builder put Aqara H1 switches on prettymuch every switch (except some multi-point ones - I’ll figure them out myself later) and Innr spotlights in every room (and outdoor lights too).

This last week I finally got to getting started with HA and it’s been… challenging… to say the least. At several points I came to the conclusion that the H1/decoupled thing just didn’t work, which was gutting because I had based so much of how I wanted the house to work around it… but… I got there in the end!!! They’re working now - in all their decoupled glory. I still have many hours of setting up automations ahead of me to have them set up as I want, but the bare-bones functionality is there. As such I wanted to share what my set up is and a couple of the key hurdles in case it’s any use to anyone else.

Setup: I’m running HAOS via Proxmox on a Lenovo Thinkcentre Mini. I started off with ZHA but almost immediately realised I needed to pivot to ZigbeeMQTT to have any hope of getting decoupled work. My dongle is a Sonoff Dongle-P. I Initially got a Dongle-E before realising that was a bad move… it might be that decoupled can work with the E, but it didn’t for me. I also had a bear of a time getting ZMQTT set up due to some glitch where it wasn’t saving the config during setup, but that’s a whole different story and I got there in the end.

My Aqaras are a mix of WS-EUK03 and 04.

Right, all that done I got the first of my Aqara switches paired to ZMQTT, working as switches, but… no decoupled. I read many forums, jumped through many hoops, nearly gave up multiple times, but in the end I think the two critical moves I made were as follows:

  1. Updating the dongle firmware. Again this was a bear of a process because the bootloader button on the dongle refused to work so ended up going the Python route which was a bit outside of my comfort zone, but there was an excellent guide on youtube.

Once I had done the update suddenly my H1s were showing the decoupled option, and could be decoupled, with the switch no longer cutting the power… but still I was seemingly getting no report of switch presses, and no option to use switch presses as a trigger in automations.

  1. Again I went round in circles for hours and almost gave up. And then I came across a post on reddit (I wish I could credit the user but I’ve lost the post in my sea of tabs and now can’t seem to find it). The gist of it was: The H1s will not initially show their switch responses, you have to ‘train’ ZMQTT on what they are capable of. You literally single click on the switch a half dozen or so times in succession, then do the same with double clicks, and only then will single and double click (and supposedly long click but we’ll get to that) will show up in HA.

I thought “surely it cannot be that simple?!!”… but I went to my nearest switch and single clicked it a bunch of times (a couple of seconds between each), then the same with double click… I went back to HA and there they were :crazy_face:

According to the same user, the one caveat is that they will be forgotten after a reboot, so if you reboot you have to go round and do the same little training procedure for all your switches. A bit of a ball ache but a small price to pay to have them working. Also the reddit poster reported having single, double, and long press working - I have single and double working on all mine without issue, but can’t seem to get long press trained in. Still, it’s a niggle and far from the end of the world - the core function is there and that’s all I care about.

So there you go… maybe useful to someone. It’s such an amazing setup if you can get it working - you can be so creative with how the switches work, all while not having to worry about ever changing their batteries, and not having your smart bulbs ever power down & drop off the network. Perfection.

1 Like

Interesting, thanks for posting that information. Glad you managed to get there in the end! Sounds like there is hope for decoupled mode in that case. There are several Aqara decoupled mode issues on Z2M Github, including the one I raised myself, but have’t had any response. I also came across some info after reading online about requiring coordinator firmware updates which update the zstack on the USB dongles, but I am running the Sonoff ZBBridge with Tasmota. I’ll certainly give the ‘training’ of the single/double clicks a try and see if it makes things work, and if so, i can add that to my support issue in case it helps.

Hey thanks for your post.

Can I ask, are you using the H1s with neutral or without neutral? I bought 2 H1s without neturals and settled on my kitchen lights just using the normal mode, but I was hoping to switch my landing light to the H1 without neutral to be used with my IKEA smart bulb but because the decoupled mode didn’t work, I gave up.

Thanks

Ah, they are with neutral… sorry, I totally meant to mention that. I actually specifically requested that the house was wired with neutral as I remembered seeing somewhere that the with-neutral H1s play better with decoupled mode (might be that it’s standard to have neutral now anyway, but I wanted to make sure).

Well I tried with my WS-EUK04 (double rocker with Neutral) using the several presses of single, double or hold, but couldn’t get anything to actually register. It is just empty strings of " " being sent for a single or double press, and a ‘NULL’ being sent for hold on my switch when in Decoupled mode.
I had no problems with my WS-EUK03 (single rocker with Neutral) in Decoupled mode, so it’s frustrating that the double rocker won’t play nicely in Decoupled mode!

Same situation for me. Only getting empty strings for action on H1 double rocker without neutral. Useless unfortunately

@mkolar This is the issue I raised, if you can add anything to it, although yours is without neutral:

Same Issue here,
I’m using Conbee III with zigbee2mqtt and on decoupled mode is not sending any actions.
I updated my Conbee FW to the latest (0x26500900) but no luck.
I even tried controlling the switch by removing z2mqtt and using ZHA but still the same problem.

Have you tried deleting the switch from z2m completely and then re-adding it since updating your Conbee firmware? I’ve just bought a Sonoff dongle-P to replace my Sonoff ZBBridge, which im hoping will allow the decoupled mode on this switch to work. I just need to bite the bullet and take down my zigbee network and rebuild it from scratch with the new dongle…