Aqara Wireless Switch added to Phoscon but not available in Switch editor

I have added a new Aqara Wireless Remote Switch to deConz/Phoscon, and it’s listed under Devices-Switchs as “Vendor Xiaomi”, Product “Transmitter 2-gang WXKG07LM”, Version “20190329” (also visible in deConz interface)

But I not able to add it to any light group in Phoscon, it’s not visible for any reason. I can see the device in Home Assistant->Devices as “lumi.remote.b286acn02”

I have configured all my switches in deconz, and I don’t understand why this new Aqara is not available under “Link switch” in Phoscon. Any idea?


Have you tried updating phoscon to newest version and also updated the firmware of your zigbee controller?
I recently had the same issue and all that showed up in home assistant was two new entities called “smart plug”.
I tried removing and then re pairing the switch many times and got different outcome from time to time.
Then a new firmware was released and it fixed the issue in my case.

Why should you be able to add a wireless remote to a light group? That doesn’t make sense. A smart switch that physically controls a light makes sense, but a wireless remote not.
I mean if you turn on the light group which includes the wireless remote, what should it do? Turn on the remote?

It’s not a lightgroup in Home Assistant, but in Phoscon (they work a bit different). I configure all physical switches/buttons in Phoscon, since it’s a lot easier than doing the same in Home Assistant. Response is also faster. I do everything else in Home Assistant.


Ah, so you are binding the remote to a light group to control it if I understood correctly?

Do you still see button presses in Home Assistant from switches/buttons linked to a light group in Phoscon? I was always wondering this but was too lazy to test it.

same here, just paired a brand-new WXKG07LM today.
My deCONZ (ConBee II) is running 2.05.88 (Firmware 26670700) which is the latest stable. I don’t mind trying a newer beta if anyone can confirm that it will register the Wireless Aqara D1 switches properly.

I don’t mind doing the automation in either, Phoscon or Home Assistant. But both is not possible currently (with my versions).

Bt the way, the D1 Wall Switch (no neutral) with 2 buttons QBKG22LM works fine for me.


WXKG07LM doesn’t seem to be in the list of supported devices (yet).

Anyway, this really has nothing to do with HA. You might have better luck asking the question here.

agreed, it’s not an HA issue.
(the QBKG22LM is also not on the list but as mentioned works fine - entities for left and right switch button are properly exposed to HA via the REST API).

I’m sure it does, all I’m saying is t might be better asking the question somewhere else.

I upgraded deCONZ to 2.7.1-stable (latest, just released two days ago) and now the WXKG07LM and WXKG06LM work fine. I can use HA automations as well as directly map triggers in phoscon to zigbee targets :slight_smile:

Yes, great! It’s working in the new version.

Hi I have just got a D1 Wall Switch (no neutral) with 2 buttons QBKG22LM.
And i cant seem to pair it to my Deconz Conbee 1 Version 2.09.00 / 23/12/2020 Firmware 26390500.

Is there a way of doing it I have tried to pair it by holding down a button until it flashes blue and started the deconz to look for switches.

But it does not come up.

Any Help

have you tried this?

Thanks I ended up getting a doing it on a

So I have Deconz for everything and zigbee2mqtt to do this switch.