Home Assistant Community

Aqualogic Component Troubleshooting

#1

I am having difficulty getting the aqualogic component to work properly and was hoping someone may have experience and can assist. I have the RS485 ethernet controller hooked up to the aqualogic control board. I can see the RS485 on the network and access its webpage config. I have validated with others on the home assistant chat room that my configuration.yaml is correct per the component spec page. I have attempted to include both the IP/port of the RS485’s network address as well as the TCP server address and port noted in the RS485 config (on the ‘serial’ page - of which I understand absolutely nothing on there!). I cannot see any logs indicating errors in Hassio or other ways of troubleshooting. The sensors all display with an ‘unknown’ status. Any thoughts on what I can try?

Thanks!

#2

I just went through this, here are a few things to look at:

  1. Make sure you have the RS485 wired correctly. On my adapter there are 3 connectors: A, B and G (grnd), my RS485 on my prologic board has 4: Red, Black, Yellow, Green, you need to connect A to Black, B to Yellow and G(grnd) to Green. Red is not needed

  2. On the RS485 adapter, make sure you set: Baud rate 19200 bps, data size 8 bits, parity none and stop bits 2. The default rate on my adapter was 115200 which won’t work. Set local port number (this port goes in the yaml config along with the IP of the adapter) and the work mode to “TCP server” (default is TCP client)

  3. If you still don’t see anything, then you will need a USB to RS485 adapter to plug into your laptop/desktop to troubleshoot the data coming from the board, I used one from DSD Tech (less than $20 on Amazon) and the software that came with my RS485 adapter to see that data was coming from the board.

If you still don’t see anything, then it could be a board issue or your wiring.

#3

Thanks. I now have it reading properly I just can’t get the switches to work. I’m guessing my board sends different commands than the standard so I will have to get the USB adapter and do some experimentation. Assuming I can figure that out - what file do I update in order to add the custom commands?

Appreciate the reply.

#4

Try sending the commands multiple times. I thought the controls weren’t working on mine as well but then I realized that sometimes you just have to select it 2-4 times for it to work.

I’m not sure yet about customizing, I have the same question as I would like to add the ability to send a code to switch my valves between pool/spa. I’m new to HASS so currently digging into the docs to figure out how/if I can edit the code to add in a new control if I know the code I want to send.

#5

EDIT: looks like I didn’t try enough times - after about 30 attempts the filter turned on. I have not been able to get any of the other switches in the component to do the same. Would be awesome to figure out how to pause the “noise” so the button clicks worked every time…

Given I have a dedicated heater button on remote, is it just a matter of capturing the hex and adding a switch to the Python?

I tried many times with the switches but nothing worked. Thinking it’s a specific code issue. I have the usb so I’m going to give that a try but Just don’t know where or how to make the updates!

I also would love to do a pool/spa switch as well as a heater… I have dedicated buttons on my wireless remote for each now.