AquaTemp heat pump controller integration (custom climate entity)

Hi everyone

Aqua Temp cloud API provides means to communicate with and control variety of heat pumps used in swimming pools. The aquatemp integration creates custom climate entity that controls target temperature, HVAC (auto, heat, cool, off) and fan (low, auto) modes. It also reports basic heat pump parameters. The API is based on @dst6se aquatemp shell script. Project description and setup instructions are available at:

Hope you find it useful.

Sid

4 Likes

Thanks for making this integration, I’ve converted to using it instead of the MQTT one that someone else created and its working fine.

On your git, someone did mention that occasionally it is locking up and stopping updates that require a restart of HA, and I’m experiencing the same thing. I assume it’s to do with not handling a connection error to the aquatemp API correctly and the script breaks, any chance you confirm this is the case?

Glad to hear it. Please make sure you’re using the latest version of the repository as the latest commit should have solved that issue. Is that the case?

I’m still seeing the temperature freeze and some point, whats the best way to get the debug needed? A restart of the supervisor core sees the issue go away but it tends to come back.

Hi there :slight_smile:
I have the latest version running at two sites. It’s a great integration and works well when it works. After a couple of days though, (not a fixed period), it does stop working. A restart of Home Assistant solves it. Any ideas to get around this?

The way the integration works now is that it re-logins whenever there’s an error which in principle should solve any problems. Are there any errors in the logs?

Thanks for the reply,
I get this over and over, until restart.

“2021-11-23 23:51:46 WARNING (MainThread) [homeassistant.components.climate] Updating aquatemp climate took longer than the scheduled update interval 0:01:00”

Since restart, ±24hours ago, no issue.

Trying to setup this one:
and I get:

2022-01-09 22:12:35 ERROR (MainThread) [homeassistant.components.climate] Error while setting up aquatemp plat
form for climate
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 249, in _async_setup_platform
    await asyncio.shield(task)
  File "/usr/local/lib/python3.9/concurrent/futures/thread.py", line 52, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/config/custom_components/aquatemp/climate.py", line 33, in setup_platform
    add_entities([Aquatemp(config)])
  File "/config/custom_components/aquatemp/climate.py", line 62, in __init__
    self.login()
  File "/config/custom_components/aquatemp/climate.py", line 289, in login
    self._token = r['object_result']['x-token']
KeyError: 'object_result'

The username set in configuration.yaml ; is this the username you set ; or the email address you use to login?

the mail address one, works like a charm this integration, many thanks! very usefull!

1 Like

Works like a charm! Thanks for sharing <3

1 Like

Purchased an Alliance Heat Pump inverter with the wifi module handled by the Aquatemp app. Can’t seem to find your custom aquatemp component on HACS as a repository. Would be great if you could point me to the right repository.
Thanks for all your support
Best
Ben

Sure, here’s an instruction how to do it:

I installed with HACS
Restarted
Updated configuration.yaml file. Only fields changed are Username and password.
Restarted Again

I can see new climate.aquatemp entity but the status displays unknown. It has attributes but the sensors are all showing as unknown.

Also added the logger line to debug.
‘’’
2022-08-24 17:52:42.464 DEBUG (MainThread) [custom_components.aquatemp.climate] {‘error_code’: ‘0’, ‘error_msg’: ‘Success’, ‘error_msg_code’: ‘’, ‘object_result’: {‘role_name’: ‘User’, ‘user_type’: ‘Customer’, ‘user_id’: ‘1562411838115684352’, ‘user_name’: ‘@’, ‘nick_name’: ‘’, ‘roleName’: ‘User’, ‘x-token’: '********’, ‘real_name’: None}, ‘is_reuslt_suc’: True}
2022-08-24 17:52:42.692 DEBUG (MainThread) [custom_components.aquatemp.climate] {‘error_code’: ‘0’, ‘error_msg’: ‘Success’, ‘error_msg_code’: ‘’, ‘object_result’: [], ‘is_reuslt_suc’: True}
2022-08-24 17:52:42.692 ERROR (MainThread) [custom_components.aquatemp.climate] Error logging in. Will keep on trying.
‘’’
Feels like I’m missing a step

Authentication itself is successful, but then there’s empty device array (object_result: []) in the second response. Do you have your pump available in the aquatemp mobile app?

Yes I do.
The device was shared with me by the installer however, who installed it in his account first. I paired my heat pump directly with my app and the information is now pulling through.
Thanks, this solved my issue.

Do you know what code: T12 is?

awesome thanks a ton - wasn’t aware that a few repositories need to be installed as custom ones

Great work, Thanks

1 Like

Looking for the Amp or Watt field. From searches it looks like this information is sent along with the API response.

No such field AFAIR. Search the forum as it was discussed some time ago.

Is this integration still working for people?
I’m getting

2022-09-20 06:40:45.848 INFO (MainThread) [homeassistant.setup] Setting up aquatemp
2022-09-20 06:40:45.848 ERROR (MainThread) [homeassistant.setup] Setup failed for custom integration aquatemp: No setup or config entry setup function defined.
2022-09-20 06:40:47.999 INFO (MainThread) [homeassistant.components.climate] Setting up climate.aquatemp

when I restart HA these days.

All I’m doing is cloning the repo and then linking the aquatemp/custom_components/aquatemp directory into my custom_componants directory in HA.

This has always worked before but seems recently that something has broken.

So I’m curious, does the Aquatemp integration still work for people on the latest HA versions?

many thanks