AquaTemp heat pump controller integration (custom climate entity)

Merged. Amazing work @bar!

I have little experience with github and HACS, so I just added you as a collaborator. Please go ahead updating it as needed.

Thanks

regarding brands, I can promote it as well if you would like.

Did you update label of latest release to 3.0.0?

Checked issues (7), seems that all of them can get resolved with the merged PR.

Btw, I managed to find a document with much more protocol code but wanted to focus on the crucial functionality, will share the the document later when I’ll be next my laptop.

1 Like

np, will try to get to it later today

Do we have an eta for 3.0.0? When trying to add aquaremp, 2.2.2 or older version is available.

Having some problems. I have an old version (two years) of the Aquatemp integration in HA which works fine. I tried adding the new radical-squared version and while it accepted what I now know was an incorrect password it shows no devices. I have now used correct password, still nothing. I also tried adding the HiTemp app, which I assume is the later version of Aquatemp, but havent gone as far as reseting the connection. I am running the Aquatemp app but now cannot login. Not sure whats going on, what do I need to to delete the old app, old integration. Appreciate any helps as i’m now in a bit of confusion. Thanks

Update on this - I have reset everything related (removed references to previous Aquatemp integration from config.yaml.
Do I need to uninstall the elements of old aquatemp installation. If so how do I go about that? Delete the related entities?
I am logged in successfully on the App. But get the following error on the new integration:
2023-06-15 14:07:05.373 ERROR (MainThread) [custom_components.aqua_temp.managers.aqua_temp_api] Failed to login, Please update credentials and try again
2023-06-15 14:07:05.479 ERROR (MainThread) [custom_components.aqua_temp.managers.aqua_temp_api] Failed to login, Error: 401, message=’’, url=URL(‘https://cloud.linked-go.com/cloudservice/api/app/user/getUserInfo.json’)

Appreciate any advice.

Anyone got any advice/help on this please?

Thank you, excellent work.
I installed AquaTemp for a Duratech Durapro-21R32.
I works fine, but I get some strange values (like Hot water temperature 300 °C).
Is that okay?
Is is possible to change the operation mode (from normal to silent mode).
There are more values available (like fan speed). Is is possible to integrate those in HA?


Thanks

Matthias

Does anyone know what the setting of F01 does? Mind (Astral Viron iHP 195) is set to DC-1(MXL169). I haven’t been able to find any reference material online as to what this setting does for the various different options it has.

Is there someone who has the Hi-temp app working with Home Assistant? I have the Hi-temp app with my heatpump and get a credential error when installing the integration from radical-squared. Choosing aquatemp in stead of Hi-temp works when installing, but then the climate entitiy does not work and is greyed out.

On the repo I saw that there are more people having this problem. There is an Issue made for this where more people mention this error, but there is no action taken as far as I know or can see.

Did someone get this to work and are you willing to share the way how.

Thanks!


what am I doing wrong ? The add-on downloaded from HACS, the entered login details are accepted, then receives a message about the lack of devices or entities. In the Aqua Temp app, the heat pump is normally visible.