Ariela Android app and VPN issues

@Ionut - I read your other threads on Ariela app and they were very helpful, please see if you can help with this one.

Ariela app is working fine on my Android device when I am on my home WiFi, I installed Open VPN on my firewall and able to connect my phone (without wifi) to home WiFi using the VPN client. And while connected to VPN I am also able to ping the HA server machine from my phone.

But when I use Ariela mobile app to access the HA server while connected to VPN, it shows error and provides options to either add a new HA server or configure an existing one. I have tried both options and manually added the IP address of HA machine (that I am able to ping) with 8123 port but it still does not work.

Since a successful VPN connection gets me on the home LAN and the firewall rules are set to allow all, I cannot understand why Ariela app is not working through VPN.

I will really appreciate any pointers on the subject!

Have you tried to connect to the home assistant UI using your web browser?
Ping is ICMP, and thus is allowed by default in most firewalls.
It could even be the firewall on the machine that hosts home assistant that is blocking your connection attempts.

Great suggestion, I should have thought of that!

While connected on VPN the browser is able to access HA landing page, tried configuring server settings in Ariela but it still does not work. The actual error message is:

Connection to Home Assistant server failed. Please check the URL/IP provided and try again.

I copied & pasted the URL from browser into Ariela so that possibly eliminates any typo.

What OpenVPN client are you using on your Android device? Is the Ariela app allowed to use the VPN connection? I believe an app’s access to a VPN connection can be blocked both in the VPN client app and in Android’s standard settings.

Its OpenVPN app available in Google Play Store. From OPNSense which has OpenVPN add-on installed & configured, I had to download a config file and certificates that were imported in Android app. The phone connects to VPN as I get the IP address with correct subnet (of VPN) and also able to access all other devices on home network. So not sure why Ariela would be the only blocked and not sure where to unblock it in the settings.


There are two popular OpenVPN clients for Android, that’s why I asked.
I use the open-source client by Arne Schwabe. For each profile, I can choose which apps are allowed to use the VPN connection.

In Android system settings, there seems to be a related setting in Apps & notifications > All apps > app_name > Data usage.
I haven’t played with these settings, so I don’t even know if they work, but they could possibly be the cause of your problem.

If this does not help, I’m afraid I can’t help you. I’ve never used Ariela and it does not seem to be open-source software. If you can successfully log in to Home Assistant from your web browser but not from the Ariela, it must be something specific to the app.

Thanks and that is good intel, I will try the app by Arne Schwabe and post updates.