Ariela - Home Assistant Android Client

yes, because I had previously entered that name (with apostrophe) in the Android settings when I first got the phone.

Hi, this app is amazing! I was about to implement my own until I found it, really thank you.
I’m wondering if anyone else has issues using the mic when the microphone sensor is enabled. I’ve been failing to send WhatsApp voice notes when the sensor is enabled.

1 Like

I was just wondering if you have been involved with the development of the Home Assistant Android app? I know in the past you had offered to help (when Ariela was suggested to be the “official”). So I was just wondering if you were involved. I have both installed just so I can watch as the HA app evolves - still use Ariela though since I started with that.


I will have to check but i believe Ariela has exclusivity over microphone when used.

I didn’t been involved until now in the official app development, i had many things to do this period and you can see that also in the Ariela development (there wasn’t any update for 2 months now :frowning:) Still next week i plan small update on Ariela and trying to work as before.

Hi all,

I’ve discovered this great app and so far I’m really impressed! Of course, the $5’ish spent is well spent :slight_smile:

One of the key feature I was looking for is the TTS service. I’ve just started playing with it and testing on a Samsung Tab A6 and a Huawei Mate 30 Pro.

Over night, TTS stopped working on the Huawei (Ariela are already made battery-proof and availability sensor in HA did show it was last seen a minute ago). I use Build-in MQTT. I had to go into Sensors and turn off and back on TTS sensor, then MQTT was working again.

Where should I start troubleshooting? Ariela build-in MQTT? TTS engine on Huawei?

I just installed it on the Samsung tablet and will see in few hours without touching the tablet if it also stops working there.

1 Like

I believe to use the image tag, you have to use a URL, and I expect that also means you need to put the image in the /config/www/ directory then use http://IP:8123/local/5/mail_today.gif"

Also not sure how it will handle the GIF vs a normal image…

If your mobile does not have access to HA server you’ll also have to add force_image: true to download the image.

I think I fixed it in a way thats workable for me. I just added the gif to a camera and then used the camera as a stream_source. Now when I click the notification it takes me to the rotating gif image of my daily mail. Looks like Android doesn’t support gif images within a notification. Thanks for the help though.

Please enable debug mode in Ariela, and if it happens again, send them to me using contact function.

Indeed Android doens’t support animated images on the notifcation. Maybe what i could do in the future is adding a new floating window were you can preview automatically gifs / video data from remote?

that would be interesting

I think that too :smiley:

Hi @Ionut, the Huawei issue was the extensive battery optimalization performed by Huawei. I was able to disable them all after a while, and TTS now works perfectly!

1 Like

Hi @Ionut,

Since upgrading to 0.107.0 i’m getting these errors and my location isn’t updated:

Log Details (ERROR)
Logger: homeassistant.util.logging
Source: util/
First occurred: March 18, 2020, 7:43:15 PM (852 occurrences)
Last logged: 12:08:46 PM

Exception in update_data when dispatching 'mobile_app_location_update_72cad3393d914d48a7e7f3bexxxxxxxx': ({'gps': [38.xxxxxxx, -9.xxxxxxx], 'gps_accuracy': 17, 'battery': 100},) Traceback (most recent call last): File "/usr/src/homeassistant/homeassistant/components/mobile_app/", line 151, in update_data self.async_write_ha_state() File "/usr/src/homeassistant/homeassistant/helpers/", line 297, in async_write_ha_state self._async_write_ha_state() # type: ignore File "/usr/src/homeassistant/homeassistant/helpers/", line 320, in _async_write_ha_state state = self.state File "/usr/src/homeassistant/homeassistant/components/device_tracker/", line 105, in state self.hass, self.latitude, self.longitude, self.location_accuracy File "/usr/src/homeassistant/homeassistant/components/zone/", line 102, in async_active_zone zone.attributes[ATTR_LATITUDE], KeyError: 'latitude'

Since the update of HA every member of the family is marked as away. I don’t see any reference to Ariela on the breaking changes of this version. Did anything changed on HA that could be throwing this error?

Hmm…thank you for reporting this. Let me see if some changes occured there.

1 Like

Hi @Ionut ,

After upgrading to 0.107.1 everything is working fine again. Everyone is marked as Home (thanks to COVID-19) and no errors on the log.

1 Like

Glad to hear that :smiley:

Whenever I try to start Ariela on my Smartwatch (Fossil The Carlyle HR Gen 5), it says “Loading…” and then the app crashes. I tried reinstalling but with no success. Any tips?

I will check this one in a few days :smiley:

Can you confirm that Ariela is up and running on the phone?

Any status updates for WiFi RTT? Just checking every few months to see if it’s still in the works. Really can’t wait to have high precision indoor positioning available. Will really step up my automations in a huge way.

Would it be possible to implement a watchdog system for the connected HA instance such that if it failed to respond (when Ariela expected it to i.e. on the home network) then an alarm could be raised?

I’m having a hell of a time trying to get ariela removed from home assistant. I first removed the integrations. Then restarted but the device tracker persisted. So i looked into the problem and others said to modify the files in .storage so i went through each and every file in there and removed anything related to ariela. I also went ahead and deleted my homeassistant.db file just for good measure. After restarting again the device trackers for ariela are still appearing. Can someone explain what i could try next to get this removed completely?