Ariela on android 5

Hi @Ionut ,

I have an indoor station, that runs on android 5, no playstore on it…
I installed apk from apkcure, the version match from playstore…
When I run it, I get the blue background, with below a bar “server not configured” …
But then what? When I click on it, the app just closes? Do I need to install another dependency? Like WebView is also need for HA companion?

Thnx in advance

Seems my indoor panel doesnt have webview, can i use your app without it?


Looks like Arial was abandoned. Hasn’t been updated since Feb 19, 2021. I had it working on my old 4.4 tablet for a while, but it only managed to keep track of some sensors. Using it for UI never worked for me. On older Android devices the WebView isn’t compatible with the newest version of the HA frontend. Chrome has it’s own WebView so you can install it and try viewing HA. I was using Tasker with AutoTools WebScreen that would open a Chrome Custom Tab to pull up HA.

I managed to flash LineageOS that bumped my old Tab3E from 4.4 to 7.1 and the official companion app works now. Maybe see if there’s a custom ROM for your device that’s a higher Android version.

1 Like