Asrock Q1900M

Sorry if this question is misplaced, I’m not sure where to leave it.
I just move my installation of HA from docker to an old notebook I have. But with the lack of UEFI and now is having problem with the disk, I want to move it again. Today I remembered I have an Asrock Q1900M with 4gb of ram and 120 SSD. Will I be able to install HA OS on this machine? For what I search in this page it has UEFI.
Well, I hope some can give goods news.

It should work. And if not, it should be a quick test to find out. I would follow the generic x86-64 install guide, but you probably know what to do already given you have tried that on another notebook.
Generic x86-64 - Home Assistant (

Yes I tried but no luck. I’m not sure if the problem is the pc or the instalation process. I will write it here, but please tell if this should go in another forum.
I follow the generic x86-64 guide in linux, balena-etcher write the info in the disk. Then i tried to open the disk with gparted to change the data partition size, to extended, but i get this error.

I tried both option Corregir (repair) and Ignorar (ignore)
In both cases Gparted show this partition scheme.

with unknow partition type.
In no case the hard drive boots

What have you done or checked in your BIOS so far?

Also when you say the hard drive does not boot - what did you see?

And how / from where exactly did you do the balena-etcher step?

Sorry, while I was testing to give the answers, the HA pc power source died tanking with it the rest of the computer. So now I will return to the docker version while I repair and old notebook to use it for HA. Sadly, this notebook hasn’t UEFI, so I will be a Debian installation.