Assist does not understand anything (Resolved, sort of)

No matter what I ask of Assist I get the response “Sorry, I couldn’t understand that”.
Any suggestions will be appreciated.


For Alexa, I had an old intent_script statement in my configuration.yaml. When I removed it, Assist started working. Interestingly, when I reinstated it, Assist continue to work. Oh, well!

same here, the Assist function does not work. It always tell “Sorry, I couldn’t understand that”.
Nothing works. Even simple requests.

I have “default_config:” in my configuration.yaml.
I also tried to add “conversation:” to my configuration.yaml, but this does not solved anything.
I’ve setup my users language as English (native language is NL, but that does not work either).

What can be the cause and solution to this problem ? Anywhere to debug the Conversation integration ?

1 Like

Same. No phrase is ever understood, even with the explicit wording from github/intents. Language is set correctly.

Yeah, same for the past few months

Any news? Same problem for months

I’ve recently tried setting up the local assistant too (just text for now). Everything I typed returned the same “Sorry, I couldn’t understand that”.

I then tried using the device name. Instead of “Turn on livingroom light”, I typed “Turn on lr_bulb”… and this worked, so maybe try using the exact name of the device to see if that works?

If that works, the way I changed it to accept “livingroom light” was to click on “Settings” > “Voice assistants” > “Expose” > “lr_bulb” (this is one of my device names)… and adding the alias “livingroom light”.

I can now type “turn on livingroom light” and instead of getting “Sorry, I couldn’t understand that”… it now turns on / off the livingroom light.

Now… I’ve just gotta figure out how to get it say something so I test its voice… like:
say “hello”, repeat “hello”, echo “hello”, etc - lol

This might mean learning where the intents are stored and how to make custom intents.

Assist seems to be VERY limited atm… asking things that Google just figured out by itself like “What is the temperature” (which gives outside temps from weather forecasts) … or “What is the temperature inside” (which gets the temperature from one of my internal sensors - no idea which)… just doesn’t work at all in my Assist… and I’ve no idea how to add intents, commands, etc yet -.-

Adding an alias “Livingroom temperature” to the aqara sensor “lr_air Temperature” under the “Settings” > “Voice assistants” > “Expose” > “lr_bulb” … seems to allow me to type “What is the livingroom temperature” and get the response.

Even though there are lights in the “livingroom” area though… asking it “Turn off all the lights in the livingroom” still doesn’t work. It seems that asking ANYTHING with an area seems to not work for me atm.

1 Like

Same issue. Anyone from HA to point us in the right direction?

Any updates on this I have the same issue…

Same problem. I tried adding an alias to one entity. It worked, at least with the text query. Not so much with my voice. I have 246 devices and 1392 entities currently, and it is not practical to add aliases to each one. The devices are already properly named, and Assist should be able to use those device names.

A list of the type of queries that Assist actually supports would be very helpful, also.

1 Like