Assist feature worked, then stopped working after OpenAI

Right out of the box with core 2023.3.1, I tried the “assist” feature in my dashboard and no matter what I type in there, it responds “Sorry, I couldn’t understand that” so, I decided to try integrating OpenAI as well, which I did, and it worked, to a point.

If I asked OpenAI about my house, it would respond, but it was always wrong, as if it were a random response to keep my home secure from the AI, IDK.

Anyway, I gather OpenAI integration is not where I want it yet, so I turned it back off, and now, again, no matter what I ask the Assist feature, it responds “Sorry, I couldn’t understand that.”

Any ideas where I might look? I thought the Assist feature (while new and simple in its abilities) worked out of the box?

There’s specific sentences that you need to use.

What have you tried?

Is your language set correctly?

Yes, my language is set to english.

I have tried “turn on the kitchen” “help” and “what is the temperature” among other phrases that are supposed to wotk. It just says “Sorry, I couldn’t understand that.” for anything I type.


Any ideas?

I can comfirm that there’s an issue.

I replicated you bug but I cannot diagnose it while I’m on my cellphone

We can open an issue on GitHub / or check if there’s already one opened

Clearing cache/ restarting Home Assistant, deleting the OpenAI intégration have no effect

In my case I was just missing to add aliases for multi language support, so for me going back to HA Assistant after setting up OpenAI worked well

add aliases for multi language support

Ah, well, I don’t know how to do that, but I will look for it, perhaps that’s what it is.

It’s in the entity advanced settings.

You need to have ones spelled exactly the same as you call them in assist

Ah, ok, I understand what you mean. I do have them set that way. It appears that my instance just is not even attempting to understand anything I type. It’s catalog of words or responses or prompts or something must be missing, I am guessing overwritten while I tried OpenAI, but I have been unable to find where that happened.

Thanks for your response, should I figure it out, I will respond further.

I am having some very weird issues with OpenAI that seem somewhat similar to the issues you had - did you end up sorting them out?

No, I gave up.

Yah me too!