Asuswrt config error

I have problem with assert component which is not loaded with HA 0.107.1
I have an error:
Invalid config for [asuswrt]: not a directory for dictionary value @ data[‘asuswrt’][‘dnsmasq’]. Got None.
Was OK with HA 0.106.6
Any ideas?

My sensor from this integration stopped working too…

I’m also having issues with asuswrt. Filling my logfile :frowning:

Same issue here, no workaround/fix yet.

Exactly the same error, this occurred after upgrading of aioasuswrt from 1.1.22 to 1.2.3 between 0,106.6 and 0.107.x

I had the exact same error after upgrading HA to 0.107.x.

I went into the asuswrt component folder and edited the file. I went through and commented out every line mentioning dnsmasq because that seemed to be the source of the error, judging by the error message in HA. After doing that, I restarted HA and the asuswrt component worked correctly. No error at startup, and all my device trackers are reporting.

I still don’t know exactly what is the root cause of this issue, but I at least got it working in the meantime until this issue gets fixed in an update.


How to find assert component folder?

It depends on how you have HA installed. for me it is at /srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/asuswrt

For me the issue went away after creating the folder /var/lib/misc locally. Even though it should be accessing that folder on the router itself…
I’m using macOS to run Home Assistant in a virtual env.

This looks promising, it surely has to do something with not being able to access /var/lib/misc on the router properly, I´m comparing´s of both 106 and 107, not seeing anything suspect. If I may ask, where exactly in your tree do you place it locally? And could anyone file an issue on Github, I´m not exactly fluent about that.

I’ve reported the issue:

@frankovsky.juraj I just created the folder “misc” in the location “/var/lib” on my local machine (macOS)

1 Like

already fixed in 0.108.0b0 pre-release, thanks

1 Like

Back to operation in 0.108.