Asuswrt config not working 0.83.1


#21

Yes :grin:

We don’t know about the other parameters as the docs are a bit basic at the moment


#22

It shouldn’t be broken, it’s just lacking fine tuning.

To be fair it was just poorly communicated that this makes asuswrt independent of the main device_tracker component and therefore has its own config, the decision was fair enough.


#23

Thanks man!


#24

Mine is working using this config…
Thanks…
RT-AC88U 3.0.0.4.384 mesh configuration


#25

I must say asuswrt component is pretty useless right now as it shows me most of my devices away when they are actually connected on the router (confirmed in the admin page). This is screwing most of my automation rules. This component does not work as it was working before so this is a regression on my side.


#26

Strange, mine is literally no different after changing the config.


#27

What about “consider_home” or “interval_seconds” parameters? First one is very useful for Apple devices.


#28

I raised a ticket against git commit : Add upload and download sensors and component for asuswrt (@kennedyshead- #17757) . This is the breaking change.

I’m pretty surprised by the decision making that allowed this to move forward. In particular, Hassio users who expect an appliance to keep being an appliance have had a useful presence detection component break with next to no notification (yeah sure, figure out from release notes that your ASUS will stop being useful.)

Hassio users have no choice but to upgrade to have real bugs fixed. It boggles the mind to see this kind of thing knowingly being inserted without providing equivalent functionality.


#29

Yes this shows that this project is severely lacking control in what gets changed and released. How you can take something that works perfectly and completely brake it for many people is beyond belief. Open Source definitely has it’s downsides.


#30

It has a ‘consider_home’ setting built-in now, at least 30 seconds if not more, don’t know what it uses for interval.

Regardless, none of that should break anything, worst you’d get are stupid iPhones coming and going all the time but like I said, that’s taken care of in the defaults.

Yes, it wasn’t very well handled as has been said many times but it does work.


#31

Not like we didn’t know that’s the cost for bleeding edge, free software and you don’t have to update :slight_smile:

Some users are still on really old versions because it ‘just works’ for them.


#32

This morning only my wife (using a Lumia) was present according Asuswrt. I was away (Galaxy S8), my daughter was away (Ipad + Lumia), my PI was away too and (fun stuff) the router was away too :slight_smile:

From there a bunch of automations was flapping or not working as intended. But it seems the issue is solved (for now, need more testing to confirm): I found while reading the support tickets that you can still provide settings inside the tracker component (not asuswrt, this is so much confusing) like:

- platform: asuswrt
  interval_seconds: 30
  consider_home: 600

I tested it very quickly before leaving this morning and things were back to normal after HA restart. Need to confirm over a day.

We have a split brain config here.


#33

I’ve adjusted my config to include the ASUS WRT component as suggested. That seems to work - I now have some router speed sensors that I didn’t need. My device tracker is now not working.

I don’t see a new entity that can be used for ASUS device tracking. Can anyone suggest a config that might work in place of my original device_tracker


#34

so far, what is working for me:
in configuration file:

asuswrt:
  host: YOUR_ROUTER_IP
  username: YOUR_ADMIN_USERNAME
  password: YOUR_ADMIN_PASSWORD

in your device_tracker file (or section):

  • platform: asuswrt
    interval_seconds: 30
    consider_home: 600
    maybe other settings (not tested)

#35

Sorted. I wonder what was odd about your setup or perhaps it was a coincidental turn it off and on again that cured it :slight_smile:


#36

No, without the config in device_tracker (so only relying on the configuration/asuswrt) the device tracking was odd and completely random: I was checking in the router the client list vs HA. With the added (back) parameters inside device_tracker, behavior is as expected.


#37

Thanks e_jp, that worked for me. I had to comment out the login details from the original platform config and it worked after that.

/Dedd


#38

I was kidding though have seen that work for many others in the past :wink:


#39

I just put asuswrt in configuration but no devices are added in known_device, then reading this thread I also added the platform asuswrt in device_tracker (adding only interval_seconds and consider_homw) but also no devices are added in known_device
No error in log.

Am I missing something?


#40

Was it working before or are you trying to setup this new component?
Have you confirmed you can ssh from your PI with the HA account to your router?
Have you created the knonw_devices file yourself (manually)? If yes check who is the owner of the file.