Asuswrt config not working 0.83.1


#1

Hi, I hope someone can help. I have Hass.io running on a raspberry pi zero w. It has been going great but device tracking stopped working recently on my Asus N55U router. The update 0.83 had a fix for this issue but I have installed the update and I’m receiving a config error as per below. SSH isn’t supported on my router.

My config is:
asuswrt:
host: 192.168.1.1
username: USERNAME
password: PASSWORD
protocol: telnet

Error message:
018-11-30 21:36:07 ERROR (MainThread) [homeassistant.setup] Error during setup of component asuswrt
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/setup.py”, line 145, in _async_setup_component
hass, processed_config)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/asuswrt.py”, line 57, in async_setup
await api.connection.async_connect()
File “/usr/local/lib/python3.6/site-packages/aioasuswrt/connection.py”, line 100, in async_connect
self._host, self._port)
File “/usr/local/lib/python3.6/asyncio/streams.py”, line 81, in open_connection
lambda: protocol, host, port, **kwds)
File “uvloop/loop.pyx”, line 1879, in create_connection
File “uvloop/loop.pyx”, line 1858, in uvloop.loop.Loop.create_connection
ConnectionRefusedError: [Errno 111] Connection refused

Any assistance is great appreciated.


#2

It is known this is still broken… there is talk about it on GitHub… hopefully a fix is found soon. I just updated last night and broke all my device trackers. I haven’t really looked into the actual errors yet myself maybe tonight I’ll get a chance to look into it a little more.


#3

Have you tried setting the port to 23? Afaik telnet uses port 23 and the standard for asuswrt is to use ssh and port 22. I’m using ssh and it works as it should. I’m running hassio 0.83.2


#4

Same here on 83.2

component looks broken:

2018-12-01 15:37:35 ERROR (MainThread) [homeassistant.setup] Error during setup of component asuswrt
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/setup.py”, line 145, in _async_setup_component
hass, processed_config)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/asuswrt.py”, line 48, in async_setup
conf = config[DOMAIN]
KeyError: ‘asuswrt’
2018-12-01 15:37:35 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of device_tracker.asuswrt. Setup failed for dependencies: asuswrt
2018-12-01 15:37:35 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform device_tracker.asuswrt: Could not set up all dependencies.


#5

You have to use a different config now, pre 83 I was using…

device_tracker:
  - platform: asuswrt
    host: YOUR_ROUTER_IP
    username: YOUR_ADMIN_USERNAME
    password: YOUR_ADMIN_PASSWORD
    consider_home: 30
    new_device_defaults:
      track_new_devices: False

Had to comment that out and add this after updating…

asuswrt:
  host: YOUR_ROUTER_IP
  username: YOUR_ADMIN_USERNAME
  password: YOUR_ADMIN_PASSWORD

Then it sprung back to life. Don’t know if there are still any other configurable options as before, no mention in the docs.


Asuswrt device tracker is broken - please release a fix
Trouble setting up Asuswrt device tracker
#6

Figured out it would be something like this. It now tells me it is not configured ok. Will change it and get back if it is ok.


#7

Yeah, the docs are SORELY lacking in explaining the new device tracker functionality where asuswrt is concerned.

Somebody went thru the trouble to modify the docs for the asuswrt component and tell you to reference the device tracker docs for further instructions but then failed to update the device tracker component to actually give any instructions for asuswrt. :roll_eyes:


#8

Adding

asuswrt:
host: YOUR_ROUTER_IP
username: YOUR_ADMIN_USERNAME
password: YOUR_ADMIN_PASSWORD

was enough.

the other parameters gave an error. So you cant setup things like detection time of telnet or not.


#9

The config above, using the asuswrt: device and the reduced parameters, doesn’t work for me.

For the curious, my router is an Asus RT-N66U, firmware is 3.0.0.4.382_50702-g6c0e289.

I’ll dig through log files for clues but hopefully this will get fixed soon. I am not interested in swapping out the router’s firmware yet.

Thanks to all who have spent time researching this.


#10

I was in the same exact boat… same model everything… i just put merlin on my router (something i had planned on doing but never bothered…) it was completely painless… just like a regular firmware upgrade… and now everything seems to be working. I literally just finished turned on SSH and rebooted HA. So far so good.
I was hesitant as clearly something got broken in the breaking out of the device tracker to its own component but after seeing that I could go back to the asus stock firmware from merlin I figured it was worth a try.


#11

Thanks! This worked for me.


#12

Running Merlin version 384.7_2 on a RT-AC68U and get these errors after upgrade to 0.83.2:
2018-12-02 23:06:33 ERROR (MainThread) [homeassistant.setup] Error during setup of component asuswrt
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/asuswrt.py”, line 57, in async_setup
File “/usr/local/lib/python3.6/site-packages/aioasuswrt/connection.py”, line 65, in async_connect

Using this setup in my config:
asuswrt:
host: 192.168.1.1
username: admin
port: 2222
ssh_key: /config/.ssh/hassio_to_router_private_ssh_key


#13

Not working for me on 0.83.2.
With config file like this:

- platform: asuswrt
  host: 192.168.1.1
  username: !secret router_user
  password: !secret router_password

I receive:

Unable to prepare setup for platform device_tracker.asuswrt: Could not set up all dependencies.

19:41 setup.py (ERROR)

Unable to set up dependencies of device_tracker.asuswrt. Setup failed for dependencies: asuswrt

19:41 setup.py (ERROR)

Error during setup of component asuswrt

19:41 components/asuswrt.py (ERROR)

#14

Of course it doesn’t work, read the posts above :laughing:


#15

I’m not sure what you mean.
I read the thread and add my own experience: changing the asuswrt configuration doesn’t solve the issue for me when it seems to work for some users.


#16

You’re using this…

- platform: asuswrt
  host: 192.168.1.1
  username: !secret router_user
  password: !secret router_password

The config should be this…

asuswrt:
  host: YOUR_ROUTER_IP
  username: YOUR_ADMIN_USERNAME
  password: YOUR_ADMIN_PASSWORD

#17

Ohhhhhh. so Asuswrt in not anymore related to the Device Tracker component as I had to remove it from my inclusion (device_tracker: !include tracker.yaml). Does this means we also lose aditionnal parameters like consider_home or interval_seconds. The documentation is not clear about that.


#18

Hé, Just asking… I have an Asus router RT-N66…which Merlin version did you use and…didn’t you loose 5 ghz wifi?

Thanks


#19

This tracker was working perfectly for me and now it’s pretty much broken because of the missing parameters. Anyone know why this (horrible) decision was made?


#20

I’m using 380.70 with an n66u. I was not even aware of the 5Ghz issue (thanks for the heads up) and haven’t seen it as of yet. After looking into it a little it seems some people are blaming it on Auto DFS channel selection but I already had auto channel selection turned off, so if that is the actual cause maybe that is why I haven’t had an issue yet. But my device tracker and new speed sensors have been working perfectly…