AsusWRT integration adds new entities as disabled. With "Enable newly added entities" option enabled


The headline pretty much says it all. I want AsusWRT to add newly connected devices as entities to home assistant. And it has done that before. But now, they’re added as disabled entities (Disabled by integration). I have enabled the option: Enable newly added entities under integration options. But it doesn’t appear to have any effect.

What am I doing wrong here? Could it be a bug?

I have same situation.
Suggest you to register a bug issue on Github.

I believe it is “by design” and therefore not a bug, but regardless , there should absolutely be an options to decide so, if people want … some people with i.e open wifi, might not want ALL devices “dropping by” to be registered “enabled” … if registered at all

Disabled entity will not be shown in some kind of auto-generated dashboard.
So a user will not find out that a new device is added - unless he catches a “device_tracker_new_device” event.
Also, disabled entities are not listed by default in Settings->Entities - then a beginner may not find it too.

True, can’t argue about that, … i have my self found “a few” devices which i have no idea when/how/who , so they are still “disabled”, was wondering whether i should delete them !.. so there should absolutely be some kind of “Notification”, instead of just “leaving” entities in a disabled state with no “Notifications”

I want to use it with a blueprint for an automation that creates a group automatically with entities from a domain that contains certain name/words in them.

That way, home-assistant can automatically create/update a group called eg: Phones, which adds device_tracking entities that contain names from the family (Nicolais pixel-5 for instance). So an automatic updating group with family phones. Which is quite useful for home/away tracking.

It works well, if just AsusWRT would add the new entities as enabled, then I wouldn’t have to do it myself…

Someone please register an issue then…

I don’t mind doing it. But I’ll have to find out how first. I guess you are talking about an issue I’m github, right?

Yes, in core section.

Was this issue raised? I can’t seem to find it anywhere and it’s been 3 years since the last post in here.
I still have the same issue and can’t find a workaround for it.