AsusWRT looses connection after 5 hours

Not sure if anyone has had a similar issue, but all of a sudden the device tracker which I use via AsusWRT, loses connection after around 5 hours. I get a host timeout and then my device tracking abilities is gone. Everything else on the router, however, is fine, but I need to restart Home Assistant to get the device tracking working again.

I have tried to do a factory reset on the router (Asus AC-RT66) but that didn’t help.

Has anyone else experienced something similar?

Example:

Logger: homeassistant.components.device_tracker
Source: components/device_tracker/legacy.py:320
Integration: Device tracker ([documentation](https://www.home-assistant.io/integrations/device_tracker), [issues](https://github.com/home-assistant/home-assistant/issues?q=is%3Aissue+is%3Aopen+label%3A%22integration%3A+device_tracker%22))
First occurred: January 9, 2021, 5:03:58 PM (4276 occurrences)
Last logged: 3:05:54 PM

Updating device list from legacy took longer than the scheduled scan interval 0:00:12

-------

Logger: aioasuswrt.connection
Source: /usr/local/lib/python3.8/site-packages/aioasuswrt/connection.py:120
First occurred: January 9, 2021, 5:03:44 PM (5869 occurrences)
Last logged: 3:08:15 PM

Host timeout.

I have similar problems since an upgrade I made in beginning of December 2020. Since then my device detection works only sporadically. After restarts it works fine for a while then i start getting time-outs in the log and the device statuses turns to unknown. Then it can start working again for a while… etc…
Before the update it has worked without any issues for at least a year.
I made no changes to the config.
It seems as if the timeout limit of 12 seconds is to short for my system.
I’m running Hassio on RPi. My router is an RT-N66U.
This is how it looks in my log

2021-01-11 09:54:37 ERROR (MainThread) [aioasuswrt.connection] Host timeout.
2021-01-11 09:54:58 ERROR (MainThread) [aioasuswrt.connection] Host timeout.
2021-01-11 09:55:01 WARNING (MainThread) [homeassistant.components.device_tracker] Updating device list from legacy took longer than the scheduled scan interval 0:00:12
1 Like

Looks like the same issue as mine. I don’t know of any way to extend the amount of time before a timeout event. I am wondering if the router is just too slow to respond.
The last thing I want to do is buy a new Asus and just see the same thing happening.

Agree, my system probably need a longer time-out than 12s. As far as I can see Asuswrt does not support the interval_seconds parameter, like is available in the device tracker configuration


In that documentation one can see that the parameter defaults to 12 Seconds between each scan for new devices.
I would like to have that parameter available also in Asuswrt.
Where do I reach out to get this into the Asuswrt feature backlog?

12 seconds is already a very long time though, for something that’s on the LAN, it should be near-instant.

Absolutely, if the root cause of this issue some kind of delays it is not because of network latency, rather due to slow response times from the router. But I don´t know how to verify what is the source of the problem. Since I got the problems when I updated HA it indicates that the problem lies there.
Whatever the reason is, it should be raised as a topic to whoever develops Asuswrt, but I do not know where and how to do that.

Yes, but many people use AsusWRT, had it stopped altogether many people would be jumping up and down. Unless it only affects RT-66 users.

1 Like

I don’t have a solution, just upping the thread as I have the same issue. Also an RT-66.

Need to be officially logged, there clearly is an issue that came in with one of the updates. When I’m near my home instance ill do it.

Logged - https://github.com/home-assistant/core/issues/45539#issuecomment-767032275
Let’s hope this gets fixed, I don’t feel like buying a new router.

This is interesting because it has been working well on the RT-AC68U for several months.

It was working well on the 66 until it just stopped :slight_smile:

Anyone updated to see if the new version fixed the presence detection?

Bad news, it didn’t make a difference.