AsusWRT not finding phone

I’m fairly new with home assistant, and as a first thing I just wanted to try and detect whenever my phone was connected to the wifi. I installed the AsusWRT integration and connected to it with ssh.
Issue is that even though my phone is connected to the wifi, it doesn’t show up in the AsusWRT intregration. The device does show up when looking for devices on my router (

Anybody who can help me?

AsusWRT integration devices vs Asus router device list:

I believe I’m experiencing something similar, but the opposite away around where devices have gone offline (or away), they disappear from the router, but the ASUSWRT component still tracks them as being home. I’m tracking this to try and work out what’s causing it on my side, but it only started happening after the ASUSWRT component became GUI configuration only.

First thing to check for you - have you marked the ‘track unknown / unamed devices’ in the integration options, and under system options of the integration, mark ‘enable new entities’?

1 Like

I had already tried ‘trace unknown / unamed deviced’ without any luck, but this time I enabled it and rebooted hass, and then it worked. Kinda embarrased I didn’t figure that one out on my own…

But thank you so much!