Athom Garage Door Opener - Sometimes easy, sometimes not

I was initially very happy with my Athom Garage Door Opener - - it was much more responsive than the MyQ device that it replaced.

However, I have a more complex home network than most. Perhaps this is a self inflicted injury. I have a private network for IoT devices so they can’t be hacked and have access to my internal network. Its running on a Ubiquiti EdgeRouter X - a prosumer router with a lot of features. Anyway, it took me a long time to figure out that extra configuration would be needed to place the device on a hidden network.

The device ran continuously without fail for four months and then it stopped after updating the ESPHome addon. I reset the device - put it into wifi host mode and set the config - and it was working again.

Somewhere along the way I thought I’d try to put it on my hidden IoT network again. I was able to do this the HA ESPHome software couldn’t see it. I wish I would have know ahead of time. It has to do with whether HA or the device initiates the connection.

So, time to put it on my main network.

I tried reflashing with updated wifi info. This was probably a bad idea in retrospect. I should have put it into setup / wifi host mode instead. Something didn’t work right and now I need to flash via cable. This will require soldier header pins so I have something to connect the cable to. It seems that over the air firmware updates are convenient but can be unreliable.

Anyway, I hope this is some helpful info if anyone has similar problems with this device. I think knowing its limitations would have saved me a lot of headache.

What’s your configuration file look like?

You mention you’re using a hidden wireless network for your IoT devices - from the ESPHome wifi component page there’s this:

fast_connect (Optional, boolean): If enabled, directly connects to WiFi network without doing a full scan first. This is required for hidden networks and can significantly improve connection times. Defaults to off. The downside is that this option connects to the first network the ESP sees, even if that network is very far away and better ones are available.

By default the configuration file has host AP mode as a fallback if the device can’t find wifi. It takes about 60 seconds to enable if it can’t find the network at all - but it will periodically re-attempt and the wifi network will disappear.

So, things we need to know:

  1. can you post your ESPHome config file? Unless you’ve explicitly disabled the fallback AP then that should’ve worked for you

  2. if the fallback AP is enabled, is it turning up if you stand near the device?

  3. if the fallback AP is enabled, then possibly it is connecting and you have a problem somewhere else. You could try disabling wifi network you’ve configured and waiting a couple of minutes to see if the fallback AP starts up.

  4. what’s the wifi signal strength look like near your garage?

It’s unlikely that you’ve broken your device, but you possibly have set some very stringent connection settings and it’s having trouble connecting. Another way to debug would be to set a device up as an AP with matching settings (i.e. a laptop or some suitable software on a phone) while standing next to the unit with the password and SSID matching whatever you programmed. The device would likely connect.

I’m attempting to install this - athom-configs/athom-garage-door.yaml at e9d1218fe0d8b4631cda211d204dd3ff5ac698be · athom-tech/athom-configs · GitHub

and at this point I’m trying to flash it with esptool which only produces

A fatal error occurred: Serial data stream stopped: Possible serial noise or corruption.

Any advice? At this point I’m wondering if I’m dealing with a dead device.

Hello! Need a little help. I bought a homekit compatible athom garage opener some years ago. I set it up in our new house and worked properly. Months ago my wifi netework dropped off it and could not open my garage by it. Can open other way (with bluetooth communication), but need to open it remotely. Tried set it again, but lost the 8-digit code. Is there any opportunity to make it work in homekit? Some advice said it can be set without code, but I do jot have this option in homekit. Any idea by any body? Thanks in advance! Tizso

Hi, have you tries using the ESPHome integration, assuming you got the default version?

Can someone please help.
My Athom garage door opener works perfect in my living room connected to my WiFi router there.
But, when I set it up in my garage, it seem to not stay connected to my other WiFi router there.
The SSID turns up. I enter the password.
But when I try to add it in Apple HomeKit, it installs, but does no answer/react when I open/close. No contact.

Same procedure in my living room and it installs and can be controlled perfectly from Apple Home.

Do I need some special settings in the WiFi router to make it work? Ports, static Ip address, firewall opening?

Help very much appreciated.

It might be trying to connect to your living room router. Do both routers use the same SSID? Are they on different channels?

Post the yaml file for your Athom (make sure to hide your password) - you might need to change it so that it only connects to your garage router. Docs here.