Atlas Scientific w/ EZO Sensors on Raspberry Pi and MQTT Atlas IoT Monitoring Software

I’m starting this topic because of some of the issues I ran into when trying to connect my Atlas Scientific EZO sensors. The sensors are attached to an AS i3 InterLink full isolation carrier board which is connected to a Raspberry Pi. I’m starting off with just a pH sensor/probe and I’m using the Atlas IoT Monitoring Software.

Installing the monitoring software was fairly easy. You can find everything you need under the Documents & Downloads section on their page. I used the preferred method which is using an image file. After that I struggled setting up the MQTT with Home Assistant which now that I look back was fairly easy. I used a program call MQTT Explorer which really helped me out.

FYI the EZO board comes in UART mode and needs to be changed to i2c. This was easy to do using jumper cables such as these found on Amazon. The documentation on how to do it can be found on the AS website or by going here. Do not attempt this with the i3 Interlink or sensor attached to the RPi and make sure the RPi is powered off. You basically short the TX and PGND on the sensor by connecting them to each other with a jumper cables. Then attach the VCC of the sensor to power on the RPi which is the first set of prongs on the main strip of the RPi. Then connect the GND to ground on the RPi which is the third set of prongs on the main strip of the RPi but before powering on the RPi disconnect it, just remember where it’s at. Power on the RPi and reconnect it, wait for the light on the sensor to change from green to blue, and then disconnect the wire. Shutdown the RPi, unhook all of the jumpers, reconnect the i3 Interlink with sensor on top, and power RPi back on and if the sensor is blue or flashing blue to green then it worked.

I’m assuming you have the Mosquito Broker add-on and MQTT integration already installed in HA. To start sending the MQTT topic to HA you’ll need to fill in some information in the monitoring software. Under Endpoint URI enter homeassistant:local and your HA MQTT user name and password that you created when you setup MQTT in HA. Change the polling interval if you want. Then choose a name for the topic. This is what all your sensors will be associated with. Then check the box to enable MQTT and save everything. I rebooted the RPi just for good measure.

After doing this I opened up the MQTT Explorer and created a new connection. Enter the same information as you did in the AS monitoring software MQTT setup and then connect. You should see the name of the topic you choose popup and it’ll start communicating based on the polling interval you previously set. By expanding it all of the way and highlighting the final one you can see the data you’re sending. If you don’t see the topic then go back and double check everything.

On the right column of the explorer find the topic and copy it. You can then go to your HA and open the MQTT integration and click on configure, Paste the topic under “Listen to a topic” and start listening. If everything is working you’ll see the data being received and stop listening.

The final part is you need to create MQTT sensors. You’ll need to create a sensor under your configuration file for any data being sent using the below template.

mqtt:
  sensor:
    - name: "choose a name"
      state_topic: "the topic you copied from the explorer"
      value_template: "{{ value_json.enter one of the data values }}"

Hopefully others can add to this and I’ll expand and edit this as I learn or do more.

There was a lot of effort getting these into esphome, so that presents another option.

I honestly found more information about using ESPHome than MQTT. I’m not saying one is easier than the other but there’s definitely more information about using ESPHome than MQTT. I actually thought I took the easy route by using the Atlas IoT Monitoring Software but due to the lack of information it wasn’t. However, looking back at everything and knowing what I know now, it was actually easy to do.

For a commercial setup, Atlas are quite open about how to DIY their stuff :slight_smile:

True. It’s just a matter of being able to DIY. I only have basic programming knowledge so I’m still trying to figure everything out. Now I’m trying to figure out how to send the send and receive data using MQTT but without the Atlas IoT software. I’m struggling with that right now.

I am using the Atlas IOT Monitoring software for the time being; I currently have an ORP probe. I am new to both Atlas and Home Assistance. This has been a steep learning curve for me to get this far! :slight_smile: I am trying to figure out if what I have completed so far is correct.

I am a bit confused on a few points:

  1. Atlas Software MQTT Settings Topic? Currently, mine is /ORP/add_62/
  2. MQTT Explorer Topic that I need to copy? I don’t see the Atlas Topic: /ORP/add_62/ when I expand all of the possible drop down menus under $SYS.
  3. The final part, the configuration file. Where is this file located?

Atlas Software MQTT Settings

Below is the image of MQTT Explorer, I believe I have this part correct.

Broker options:



MQTT Explorer


image