Attr_weather_humidity error on 0.65.5

anyone recognize this error, received since updating to 0.65.5 Hassio:

2018-03-23 23:06:09 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/lib/python3.6/asyncio/", line 180, in _step
    result = coro.send(None)
  File "/usr/lib/python3.6/site-packages/homeassistant/helpers/", line 260, in _async_add_entity
    await entity.async_update_ha_state()
  File "/usr/lib/python3.6/site-packages/homeassistant/helpers/", line 222, in async_update_ha_state
    attr = self.state_attributes or {}
  File "/usr/lib/python3.6/site-packages/homeassistant/components/weather/", line 113, in state_attributes
    ATTR_WEATHER_HUMIDITY: round(self.humidity)

i dont recognize the component/weather mentioned in the last line, maybe thats homeassistant built-in?


not really sure what you’re implying here? should it be solved, or is this to be resolved soon?
btw, i dont use Darksky, so couldn’t be caused by that.

Secondly: is see a async_update_ha_state line in here, and in the reference you posted.
Is that the same error, or another thing to note and fix?

posted on the GitHub about this sensor i created recently, maybe related, since using Humidity also:

- platform: filter
  name: "Filtered humidity living"
  entity_id: sensor.luchtvochtigheid_living
    - filter: outlier
      window_size: 4
      radius: 4.0
    - filter: lowpass
      time_constant: 10
      precision: 2


Any followup on this? Still happening here unfortunately.

I’ve just found this is caused by the Buienradar component in my setup. The other weather components I use, Open weatherman and Weather seem not to cause this issue.

1 Like