Attribute: current_heating_setpoint is gone

It was there before. But now it’s temperature’. And i can’t find any breaking changes for this one

Attributes change on climate entities depending on what mode you’re in.

Thanks didn’t know that. But this is not the case. I was running this install for a long time. Using the custom:fold-entity-row card to display the current heat point attribute. Had to change the z2mqt channel yesterday and repair all the device. For all the trv’s (6 of them. Different models of tuya this attribute is now substituted for temperature. Although the mqtt messages and z2mqtt states the old one.

Those changes come from z2m, maybe you should check their breaking changes.

@moskovskiy82 do you find a solution for this? I do have this TVR: Lidl 368308_2010 control via MQTT | Zigbee2MQTT

I see current_heating_setpoint_auto in my Szene , but no current_heating_setpoint.
Is zigbee2mqtt I see those attributes if I go to status of this device.

I wonder how I could fix it to make it visible in the scene-selector

Had to change to another attribute. Read through the changelogs but couldn’t find what is causing this issue.
And once again they are there at the properties page of z2m, but not in HA @petro

Yes but that’s discovery that comes from z2m. Z2m defines the discovery information, like attributes, behavior, etc.

@moskovskiy82 :
I don’t fully see, what you mean. Can you give a hint, which property to use or
@petro : how to archive, that Z2M recognize the existing attributes?

I have no idea what you’re asking. How about you just tell me your goal, show me a screenshot of your climate attributes, and we’ll go from there.

Most likely, you’re not understanding how climate entities work now that mode is an attribute.

EDIT: Also those docs you linked actually show you how to get the current_heading_setpoint from a topic.

As a sidebar, there’s a check in the code that looks at your device and decides on creating current_heading_setpoint as an attribute.

And there has been a series of changes to Z2M in that file related to climate discovery

It might be worth raising this issue with the Z2M people as it seems like it’s a bug if it disappeared from the entity after a Z2M update.

1 Like


…that some screenshots are in german language, but I didn’t found a way to set z2m to englisch language

In Z2M I see my TVR. If I click status, I see that there is a current_heating_setpoint and current_heating_setpoint_auto.

In Settings > Scenes I try to do that:

In Words:

  1. If Schedule-Helper turn from off to on, set valve temprature to 20 degree.
  2. If Schedule-Helper turn from on to off, set valve temprature to 16 degree.

The Problem, I’ve trying to solve:

I don’t be able to set the current_heating_setpoint in the Scene, because it is not available … only the current_heating_setpoint_auto is available:

The auto setpoint seems only to have impact if I run in schedule mode, but I don’t want to use the schedule at the valve at all, because I’d like to use my HA-Schelduler instead of it.

Here is my Schedule-Helper for the HVC:

Just posted on their issues page. Thanks!