August Door Lock Not working in 0.103

My August Lock + Connect had been working fine.
I upgraded to the latest version, and I get a notification on the front end saying the august platform could not be set up, to check my config.
This may have something to do with the Python changes in this new version?, but I unfortunately am not technical enough yet to understand or fix. Who knows if that is the issue (certainly not me. I just know it doesn’t work anymore as my lock isn’t showing up on the front end).

My logs are as follows:

Error during setup of component august
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 176, in _async_setup_component
    component.setup, hass, processed_config  # type: ignore
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/august/", line 170, in setup
    return setup_august(hass, config, api, authenticator)
  File "/usr/src/homeassistant/homeassistant/components/august/", line 119, in setup_august[DATA_AUGUST] = AugustData(hass, api, authentication.access_token)
  File "/usr/src/homeassistant/homeassistant/components/august/", line 181, in __init__
    self._doorbells = self._api.get_doorbells(self._access_token) or []
  File "/usr/local/lib/python3.7/site-packages/august/", line 146, in get_doorbells
  File "/usr/local/lib/python3.7/site-packages/august/", line 296, in _call_api
  File "/usr/local/lib/python3.7/site-packages/requests/", line 940, in raise_for_status
    raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 401 Client Error: Unauthorized for url:

Any help or advice is appreciated!

Yep im having the exact same issue. my sensor to see locked or unlock still shows up but my open/closed part from the connect and doorsense dont work

I had to remove the lock from the integration, and if I remember correctly, delete the associated folder from the file system. Then I re-added the lock integration; it sent me a verification code, and next thing you know it all worked again.

1 Like

Having the same problem too after recent update. I tried removing the entities, entries from the config, and deleted the .august.conf file. Re-added the component but get the same error as mentioned above. It works fine with basic HomeKit and the August app.

You’ll need to update to 0.105.3 to fix the 429 issue. After upgrading, if you are still having trouble authenticating you’ll need to remove .august.conf and get a new verification.

The periodic need to remove .august.conf should go away once the above PR is merged

1 Like