August lock + connect no longer works

I have an August Lock and an August connect that I cannot get working with HA 81.6. I use the standard August component configuration. Phone number for authentication. I have verified the credentials using the IOS August app which works fine. When I reboot HA after adding the configuration I receive the following errors:

Error: HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /session (Caused by NewConnectionError(’<urllib3.connection.VerifiedHTTPSConnection object at 0x73352a10>: Failed to establish a new connection: [Errno -3] Try again’,))
You will need to restart hass after fixing.

As well as:

The following components and platforms could not be set up:

Please check your config.

I have tried single quotes, double quotes, and no quotes around the username and password.

did you reboot?

After every change to configuration.yaml

i have the same problem, any solutions?

I had similar problem with August lock, but do not remember exact error code. Just for reference, I deleted the August.conf file, removed configuration configuration.yaml and restarted HA. Once HA is up and running ensured that there is no August error log any more. Now add back August configuration and restart HA.
Note : If you are using lovelace UI with preconfigured UI screens, the option to enter code gets hidden under unused entities. So go there and click on configure and enter code.
This fixed my problems with August lock.
Good luck.


thanks. no need to mess with the yaml files. Just delete august.conf and restart HA, then re-enter the auth code from the SMS message and it is back again. thanks a lot!

Just had the same problem. This fixed my problem…Thanks :ok_hand:

happened again. and this fixed it again!

You should no longer have to do this once this PR is merged