Australia - Electrically Certified Hardware

Did you ever get this going well? I have a JB Hifi Pettech one which is pretty good and reliable (mobile app is awful) but I don’t think it’s flashable (?).

I assume you are using this one, which is the same as the KMart one?

https://www.kogan.com/au/buy/kogan-smarterhome-smart-wifi-pet-feeder-camera/
https://www.kmart.com.au/product/mirabella-genio-smart-pet-feeder-wi-fi-camera/3121820
http://offers.kd2.org/en/au/aldi/phJYx/

They should all be Tuya-Convertable right?

I bought a Kogan Bladeless Tower Fan but it doesn’t show via the Tuya integration (can be set up in the Tuya App though).

Set up LocalTuya custom_component and it works fine.

DPS 1 - fan on/off switch
DPS 2 - fan speed
DPS 3 - fan preset mode (close, sleep, fresh, heavy)
DPS 8 - oscillation on/off
DPS 11 - timer in hours
DPS 12 - timer in minutes
DPS 13 - unknown
DPS 101 - light switch for fan ambient light
DPS 102 - sound switch if you don’t like the change ‘beeps’

Note in the custom-component, you’ll need to edit the fan.py file to change the speed settings (original file has low @ 1, medium @ 2, high @ 3). This fan uses speeds 1-9

2 Likes

Can anyone tell me if the Kogan garden RGB spotlights are pin/cable compatible with the Brilliant ones? (They are much cheaper)

https://www.kogan.com/au/buy/mjs-electrical-supplies-brilliant-smart-wifi-rgb-garden-light-kit-bs2070206/

https://www.kogan.com/au/buy/kogan-smarterhome-rgb-smart-led-outdoor-spotlight-set-of-3/

I’m stuck here too. I just put 1 in which I think is the on/off state and the fan I was trying seems to work.

They’re cheaper, but they are also IP44 instead of IP68. Call me cautious, but I like my electronics/electrical gear to be at least IPX5 or greater, especially if they’re anywhere near water sprinklers. Although, you could just silicon the crap out of them. That’ll sort it.

PS I also just noticed that they’re also RGBW instead of just RGB. So there is some added value, I am not going to say it’s $200 worth of added value, but there is some.

Hey does anyone know if Arlec, BrilliantSmart, Connect SmartHome, Kogan, or Lenovo smart bulbs are flashable by hand? I’ve done it with Chinese ones but I’d rather buy local.

1 Like

Just for follow-up, in case anyone else decides to do this - I transplanted a TYWE2S module (pin-compatible with WB2S) into the 6921HA socket, put Tasmota on it, and it works fine, including energy monitoring.

The socket uses a HLW8032 for energy monitoring, and I set the following config:

GPIO3 - CSE7766 Rx
GPIO4 - Button_n 1
GPIO13 - Relay 1
2 Likes

Good news on Kogan V1 smart plug repair possibility.

Opening and removing the component I suspected from three failed units all showed the same thing. An X2 film capacitor that supplies the low voltage rail for the ESP had aged from its specified 0.1uF (+/-20%) to less than 0.01uF.

Replacement parts cost about $1.20 AUD. I’ll write up a how to when the replacement parts arrive (and I prove this is definitely the issue). It’s a through-hole part so easily replaced.

These film capacitors are known to age,. The self healing dielectric film between the electrodes fails over time as voltage spikes punch through it. As they age their capacitance goes down and so does the voltage available to the ESP, until it reaches a point the ESP wont turn on. However 1 year to failure is rather poor (unless your mains supply has lots of voltage spikes). So it looks like they used a substandard component. Replacing the capacitor with a higher voltage rated quality brand should provide a longer life.

7 Likes

Has anyone got a recommendation for Aus Certified Shelly devices? I’m specifically looking for the Shelly 1L.

I saw in the thread these https://smartguys.com.au mentioned.

The following Iconic Clipsal devices support ZigBee protocol: Wiser Switch Mech, Wiser Dimmer Mech, Wiser Micro Module Switch, Wiser Micro Module Dimmer. All work with momentary/push buttons or are push buttons themselves.

Example product link:
https://www.clipsal.com/products/detail?CatNo=41E10PBSWM&itemno=41E10PBSWM-VW

Example Zigbee certification link:
https://zigbeealliance.org/zigbee_products/wiser-40-300-series-module-switch-10a-2/

The trick is to make them talk Zigbee, because by default they talk Bluetooth using BLE profile, which is unreliable, slow, and is just unusable.

I was able to pair them with my existing zigbee network based on RaspberryPi + Raspbee coordinator with Home Assistant as the software layer. Any other zigbee infra should be able to pick up these Clipsal controllers as well.

To switch mechs into Zigbee mode I did the following (WARNING, this might be one-way and you won’t get Bluetooth functionality back):

  • Installed Wiser Room app, paired with mechs via Bluetooth, and upgraded them to the latest firmware.
  • While mech was powered, I pushed the button 3 times and then held the button pushed for about 20 seconds until red led flashed rapidly (when you hold the button it first starts flashing relatively slowly, that’s pairing mode, you need to wait more until it blinks rapidly). What I found interesting was that this process was not listed in AU docs, but it was mentioned in EU docs for similar micro modules.
  • Then I paired zigbee device via zigbee coordinator/gateway following the usual process.

So, Home Assistant + Zigbee integration + Raspbee + Clispal Wiser mechs work fine for me without any issues.

4 Likes

Wow, not cheap, but good info thank you.

Looks like you can get them for a bit cheaper than that but still pricey. Although I would be tempted at that price if the quality is there.

Sparky Direct

I am curious as the long term build quality that the clipsal smart mechs provide. They might be worth it in the long run. That’s assuming clipsal have a higher QA expectation than many of the new product about there.

Hi all,

Wondering if anyone has come across this before.

I’ve got two Aeotec dimmers installed today. They work perfectly except for the physical switch. I can control them via home assistant, but the physical switch doesn’t work (except strangely, s2 switch does work on one of the dimmers, but not s1)

The sparkies had to leave before we could troubleshoot much, but all the aeotec nanos they installed are working.

I installed Clipsal momentary bell press for s1 and s2. I’ve set the parameter via zwave to be momentary - this has worked for all the nanos.

The only thing I can think of is that the dimmers use the “com” for the switches, instead of tapping active (which the nanos do). This is as per the aeotec wiring diagram though.

The only other thing I can think of is I’ve got 3x bad mechs, but that would be incredibly unlikely.

Any ideas on how to troubleshoot?

edit

So the bulbs they are driving are 2x8w. But just saw the power consumption entity in home assistant, and it has it at 5w (which is below the threshold for the bypass load). Would that cause this behaviour? It working via zwave, but not the physical switch?

For the Clipsal zigbee mechs - Do these work as zigbee repeaters/routers as well?

I can confirm that’s correct wiring.

Assuming both buttons are wired correctly and not faulty, I’d check the following parameters:

[3-112-0-120] External Switch Type: S1: [3] Momentary
[3-112-0-121] External Switch Type: S2: [3] Momentary
[3-112-0-123] Control Destination (S1): [3] Load and association group 3 (Default)
[3-112-0-124] Control Destination (S2): [3] Load and association group 3 (Default)

These are the only configuration settings I am aware of which if set wrong would cause the behaviour you are seeing.

If everything looks right here, consider setting the “Reset to Factory Default Setting” option which should bring set the switch types to unidentified which should do something when you either press or hold the buttons.

If you’re still having no luck, I’d be getting your sparky to do continuity tests on the buttons to ensure they are functioning correctly. Hooking a normal two way switch to COM and S1 is another test I’d have done if the buttons seem fine.

If you have neutrals connected I very much doubt it’s the issue. If you don’t have neutrals then I couldn’t say. I’m not sure what kind of undefined behaviour one might see without enough current. Certainly seems like it could be an issue with no neutral but it working via Z-Wave and not the physical switch is not something I’d expect.

Yes, you can find the supported feature set in the testing report on zigbeealliance website for corresponding mechs. But generally all mains-powered Zigbee devices are supposed to be routers/repeaters.

Yep supposed to be, but I recently got burnt on some sengled mains powered stuff I expected to be repeaters but wasn’t

I’ve checked the parameters in HA. Under the zwave js I can easily change between toggle switch and momentary. It doesn’t make a difference

And the fact that one momentary switch is working perfectly on S2 makes me think it’s likely busted mechs, or bad wiring. Because everything else is the same S1/S2

Please excuse my ignorance, I see the following on the spec of the module, ‘3 wire design’. Does that mean they require a neutral wire?