Australian BOM Rain Radar Card

Hey thanks for following up with me!
Working great now. Love it!

Any idea why this repo wouldn’t be showing up in my HACS frontend search?

It says why in the installation instructions:


If you use HACS, the resources will automatically be configured with the needed file. The repository needs to be added as a custom repository within HACS.

1 Like

Oh man… Silly me. Never had to do that.


First step if something is not working as expected is to read the fu fine manual.


weird, dropped the files (tried both 1.2.18 and 1.3 beta files) added js to resources, rebooted but card is not showing up in the list if i add it manually it is just a white screen… installed it manually as i dont have hacs in synology deployment… can any one share their success steps to make it work? not sure what im I doing wrong… please assist

files added to www:

bom-radar-card.js 61 KB

home-circle-dark.svg 1.88 KB

home-circle-light.svg 1.95 KB

leaflet.css 13.3 KB

leaflet.js 205 KB

leaflet.toolbar.min.css 3.04 KB

leaflet.toolbar.min.js 5.43 KB

pause.png 338 Bytes

play.png 429 Bytes

radar-colour-bar.png 239 Bytes

recenter.png 435 Bytes

skip-back.png 409 Bytes


I just did a manual install and everything works. Copied the files into a subdir of www and added the resource url /local/bom-radar-card/bom-radar-card.js
Normally if you mess that up it will just give you a big red card saying it can’t find the resource.
If you post your card config I will test it on my system and check there is nothing wrong in there.

@Boroda did you get it sorted?

sorry mate, was away from pc for a few days.
Nah, does not work for me yest, the card is not red, it is just blank

here is my card config:

type: custom:bom-radar-card
frame_count: 10
center_latitude: -25.567607
center_longitude: 152.930597
marker_latitude: -26.175328
marker_longitude: 152.653189
show_marker: true
show_range: true
show_zoom: true
show_recenter: true
show_playback: true
zoom_level: 8

There’s something wrong with your custom card install or a browser extension may be blocking display. When I use your config I get this:

weird, which files did you uploaded into the www directory? can you snd me a link to it? i took my from the github page… i mean there is nothing else, files link to resource(lovelance) and the card, if card and link are correct than something wrong with the files…

Weird. Your config works for me also.
Can you see if any errors are showing up in the browsers development mode console?
Everything looks right, but I would suggest sticking the files in their own directory just so you know what belongs to what in www.

Not sure if related but mine are located in /config/www/community/bom-radar-card/

I didn’t have to copy anything as I used HACS to install it.

sorry mate dont have hacs available in synology deployment, tried putting it in a sub folder, obviously no luck :frowning:

I’ll check the list of files when I get home in a few hours.

1 Like

The list of files is correct. Missing the .gz versions, but that only speeds up loading. I installed exactly the files listed in a subdir of www and it all worked. Please have a look for errors in the console log of your browser.

nothing bad in logs,wondering if hacs put the files somewhere else …

Ok, I Know the problem now. You must be the first person to have tried installing it not using HACS.
The card creates a document to use in an iframe and for some reason that I don’t remember I hardcoded some paths in there.
Let me have a look and see if I can figure out how to make those relative or something. Or you could install and use HACS :wink: That then lets you know when there are updates as an added bonus.

1 Like

sorry mate i would love to have hacs but due my deployment (synology docker HA) not able to use it :frowning: