Auth failure using /api/camera_proxy in notification

I’m attempting to send a push notification with an image from my camera to the android app.

If I send it like this, there is no image shown and no errors in the HASS logs

message: Front Door
data:
  image: /api/camera_proxy/camera.front_door

If I change image to have the full path, like below, I still don’t see the image on the phone and I get an error “Login attempt or request with invalid authentication”

image: https://<my domain name>/api/camera_proxy/camera.front_door

I’ve also tried change it to use my local IP address the the same result.

I’m not clear is this is an error with the way the app is handling authentication (I assume it should be adding a token to the request?) or an issue with my networking setup. Any suggestions for how to debug?

Nuba Casa is configured to use NGINX reverse proxy over SSL when on my home network, and Nuba Casa remote UI when outside the home. I tested it with wifi on / off and the result was the same.

I can use local images in the www folder fine

Im using Home Assistant Core 0.112.2 and App 1.9.0-167

Hmm… so of source after I give up and post, I decide to try a different camera and it works fine.

The entitiy id is definitely correct, and I can view that camera via the HASS UI. Any idea why that particular camera would not work through the camera_proxy api?

Turns out I heard the still_image_url property of that camera configured with the wrong password. I never noticed because I only use the stream source.