Auto start HA would be error,but manual won't

I run the Manual installation on a Raspberry Pi with python virtual env and run the 3.8.6 version.
Manual run hass would be ok and everything right.
Then I write the systemd to auto start my ha.service following this link:

but it would get these wrong message,

Traceback (most recent call last):

File “/home/homeassistant/.pyenv/versions/homeassistant-venv/lib/python3.8/site-packages/homeassistant/components/tts/”, line 120, in async_setup

base_url = conf.get(CONF_BASE_URL) or get_url(hass)

File “/home/homeassistant/.pyenv/versions/homeassistant-venv/lib/python3.8/site-packages/homeassistant/helpers/”, line 90, in get_url

request_host = _get_request_host()

File “/home/homeassistant/.pyenv/versions/homeassistant-venv/lib/python3.8/site-packages/homeassistant/helpers/”, line 130, in _get_request_host

raise NoURLAvailableError
Also homekit integration would not be used,QR code will display.
These error if I ran manual start hass ,would be ok.
But systemd would error.
I am so confus where is the program or setting get wrong .
Search many of method but can slove it .
Is anybody know about this issue?