Automation condition time says false but i dont agree

I have this condition with sunset/sunrise limits with an offset for sunrise of 45 minutes. This morning it validated the condition with below:

Executed: August 30, 2022 at 6:34:14 AM

wanted_time_before: '2022-08-30T18:33:03.916464+00:00' 
wanted_time_after: '2022-08-30T05:33:47.101391+00:00' 
result: false

So how does it return false on 6:34 when that is fitting right in the timerange it mentions here? Anyone suggestions?

Are your time zone and location set correctly in Settings → System → General?

( An accurate altitude helps with sun predictions too. )

What is your time zone?

i’m in amsterdam and homeassistant knows :slight_smile:

but my real question is really: you see time executed and the wanted values before and after (copied from ‘trace’), isnt that a hint that somewhere those values are not properly compared?
OR the time before and after are not taking into account the timezone and those are GMT? then it would explain

They are but if you add one hour to them it still should not be false. 6:34 is after 06:33 and before 19:33.

Are you running in a VM?

yes Virtual Box… interesting question though

Many reported incidents of “things aren’t triggering at the right time” are often due to how the system clock is configured for a virtual system. That’s why it’s useful to know about the environment in which Home Assistant is running.

fair enough. Except for this trace log and condition not doing what the variables values say, should no longer be tied to system clock… or am i missing some logic here?

Check your Host system time and timezone.

done that, similar settings (quite consistent when installing anything, hate time discerpancies)

What does this return in the template editor?

{{ utcnow() }}
{{ now() }}
{{ utcnow().astimezone() }}
{{ now().astimezone() }}
{{ utcnow().tzinfo }}
{{ now().tzinfo }}
{{ now().astimezone().tzinfo }}
Result type: string
2022-08-31 08:18:11.309541+00:00
2022-08-31 10:18:11.310229+02:00
2022-08-31 10:18:11.310379+02:00
2022-08-31 10:18:11.311426+02:00

You appear to be on daylight savings time at the moment (UTC+2, not +1).

So 6:34 local is before 05:33:47 UTC (it is 4:34 UTC). Hence → false

so it would help to have the automation trace add timezone with the timestamp, then all should be clearer to debug and fix.
or have daylightsavings adapted?