Automation error triggered when this is added

HI All, I’m trying to follow a tutorial on hackster for a doorbell using Raspberry pi 3B. however i get this error

2020-06-10 15:56:48 ERROR (SyncWorker_0) [homeassistant.util.yaml.loader] mapping values are not allowed here
in “/home/homeassistant/.homeassistant/configuration.yaml”, line 33, column 13
2020-06-10 15:56:48 ERROR (MainThread) [homeassistant.bootstrap] Failed to parse configuration.yaml: mapping values are not allowed here
in “/home/homeassistant/.homeassistant/configuration.yaml”, line 33, column 13. Activating safe mode
2020-06-10 15:58:37 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook 8d0f2666a07ebc534455abf44b8b1c609a246674c99f0eb7d80a68f88ae29085 from 192.168.1.103

The only thing it refers too is the trigger function which i can’t seem to figure out what is wrong as it looks fine from reading the documentation on home assistant triggers.

Here is my config.yaml file

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
mqtt:
  broker: localhost
camera:
 - platform: mqtt
   topic: dev/camera
dev_publish_on_script: 
 sequence: 
   - service: mqtt.publish 
     data: {"topic":"dev/test", "payload":"ON"} 
script.dev_publish_on_script: 
 friendly_name: 'Capture doorcam photo' 
 icon: mdi:camera 
# Telegram Bot send messages
notify:
  - name: Telegram
    platform: telegram
    api_key: 2354345@4f34f3245g46465yh4th44
    chat_id: 1113241523
automation:
  - alias: Doorbell_pressed_automation 
     trigger: 
      platform: mqtt 
      topic: dev/test
      payload: 'Capture!' 
   action: 
    -  service: automation.turn_off 
       entity_id: automation.doorbell_pressed_automation 
    -  service: script.turn_on 
       entity_id: script.doorbell_pressed_script 
    -  delay: "00:00:5" 
    -  service: automation.turn_on 
       entity_id: automation.doorbell_pressed_automation 

Any help would be awesome thank you in advance.

1

You already have a scripts.yaml file. All scripts need to go in that file.

Move

inside your scripts.yaml file. Make sure your spacing is correct. Seems like you aren’t keepign the same spacing count for each indentation. I recommend using 2 spaces for each indentation level.

You also have the option of doing this through the UI.

Configuration -> Scripts -> little + button in lower right corner.

2

Customizations go inside the customization section. That section is in the home assistant section. But, it’s much easier to do from the UI.

Configuration -> Customizations -> Choose the entity -> Adjust the property in question.

Thank you that worked :slight_smile: