Automation garage door via NFC tag

I’m having issues with an automation I created using NFC tag scanning to toggle my garage door. Occasionally it works and can’t figure out the issue. This morning I scanned it 3 times and while the automation showed in the logbook and trace appears to have called the toggle it didn’t do anything. When I first set it up a few days ago I found that just adding the device wasn’t cutting it so I added the entity also. While that worked the couple times I tried it apparently wasn’t the permanent fix. Here is the automation config as shown in a trace:

id: 'xxx'
alias: Toggle garage door w/Tags
description: Open garage door
  - platform: tag
    tag_id: 1
  - platform: tag
    tag_id: 2
  - platform: tag
    tag_id: 3
condition: []
  - service: cover.toggle
      device_id: id#
      entity_id: cover.garage_door
mode: single

Here’s a shot of the trace timeline:

This showed in step details when I clicked the little arrow down next to the diagram:

I have no idea what any is this is telling me so I hope someone can help.

EDIT: for safety (don’t know if I need too) I removed tag id and such

The trace is telling you that it completed. If the hardware didn’t react, look at the hardware.

So when it didn’t work, I used my standard garage door opener and the logbook shows state change for that. I posted the other day that I was getting issues with a notification automation I set up that the garage door cover would occasionally show opening and closing states, but was good on showing open and closed states. So do you think it’s just a dying z-wave controller I have for the garage door? I am having 2 other devices in my house, a Levition dimmer switch and a GE 3 way switch, that don’t like to show the proper state, so I don’t know if that’s more an issue with my HUSBZB-1. Reading now about updating the firmware, but not sure if that would fix anything.