Automation: search for device

Issue in 2023.7.1
When I search for a device (Search for ‘friendly name’) to use it as a trigger for an automation I didn’t find it even though it is in the Picklist of all devices.

This happens with some devices (no matter what type of integration), but not with all

Works fine with 2023.6

Steps to reproduce the issue

  1. Start to create a new automation
  2. Select devices as a trigger
  3. search for device by entering the name (friendly name)

Anyone else can confirm this issue?

I can confirm that they all seem to be appearing in 2023.6

Perhaps the developers want to discourage the use of device triggers (in favour of entities) - a good idea IMO. :grinning_face_with_smiling_eyes:

If you use the device trigger, it is only the first step to find the right entity state (its a second input box)
Finaly its more or less the same and works as well.

There’s a rant here…

May be, becaus a very popular youtub channel (Simon42) explainend how to setup an automation in HA. In this video he used device/entity-state as a trigger.

Looks there are 2 different options with the same result.

As long as there are both options available, the search funktion should work…

1 Like

Why do you think the option via device (top pic) is more comlicated ?

I can confirm I have the same issue. In my installation, all of the missing devices are z-wave (JS) devices like scene controllers and motion sensors. My existing automations still exist and work, I can edit them, but I cannot find the same device in the dropdown list anymore if I re-enter the same name in the device field. This worked fine in 2023.6 and earlier.

Using the Status>Entity as a trigger also doesn’t work for me, since devices like these don’t (always) have entities for the buttons you press or the motion triggers. The only way these work as a trigger for an automation is by using the device type trigger.

Case in point:

1 Like

I have opened a case for this issue in Github:

1 Like