Automation using input_select not working any more

I’ve been triggering a bunch of lighting automations using input_selects, and they’ve recently stopped working. I can’t be sure when, but it happened prior to 0.49.0 (I’m on .1 now). I can’t for the life of me see where I’ve gone wrong.

I have my config broken out into lots of files, so you’ll have to take my word for it that my yaml is sound. I certainly get the all clear when I run hass with check_config.

Ponder the following automation:

alias: 'Front room: bright'
  platform: state
  entity_id: input_select.front_room_scenes
  to: 'Full brightness'
  - service: scene.turn_on
    entity_id: scene.front_room_bright
  - service: input_select.select_option
      entity_id: input_select.front_room_scenes
      option: Full brightness

Pretty straightforward, right? When a particular input_select is set to the option “Full brightness”, it triggers. First action is to turn on a specific scene, and the second is to set that very same input_select to the selected option. The reason I do the second action is because I have Google Assistant triggering the same automation via the API (using IFTTT).

Here’s the corresponding input_select:

  name: Front room
    - Full brightness
    - Watching TV
    - Lights off
  initial: Lights off
  icon: mdi:lightbulb

And here’s the scene:

- name: front_room_bright
      state: on
      brightness: 254

If I turn on the scene manually, it works. If I call the automation manually, it works. The input_select, however, has stopped working. It doesn’t matter if I call it from the dropdown in the hass interface, or test it via the API - it doesn’t do anything. When I turn up my logging to debug, I don’t seem to get anything useful - it simply logs the option change.

Have I missed a functionality change in a recent update? I’m tearing my hair out on this one!

Hi @korvan, are your automations enabled? (Dev Tools/States -> state ‘on’)
Maybe try initial_state: True in the automations, so they are always enabled on HA start.

- alias: 'Front room: bright'
  initial_state: True
1 Like

Gah! How the heck did I miss that? I totally knew about automations being enabled/disabled like that, but didn’t even think to check it. They were all indeed off.

Wood for the trees, ‘n’ all that. Thank you VDRainer. Very much appreciated.