Automations not loaded after restart


I’m having an issue with all my automations. If I restart HA the automations don’t appear in the panel, and also are not loaded at all. If I go to Configuration -> Automations the list is empty. So every time I restart HA I have to go and restart all automations, and then they appear and start working again.

Is there anything I have to add to the automations, or any script I can have so when HA is restarted it also restarts automations?


Mine did that for a while and then inexplicably it sorted itself out again. I had to make sure to go to the configuration tab > general > reload automations after every restart. That might help until your installation “fixes” itself :confused:

Did you set up the automations via the frontend or manually in a yaml-file?

I did some manually and some from the frontend, but none appear until I restart them

When I tried to use the automation editor a while ago I had some issues with it because I didn’t know that:

The automation editor reads and writes to the file automations.yaml in the root of your configuration folder. Currently, both the name of this file and its location are fixed. <

Just trying to make sure it’s not a ‘simple’ issue like that messing with your automations.

I’ve made more than my fair share of these kinds of mistakes :grinning:

I think that part is fine. When I restart automations, they appear again on the frontend.

Another solution… How could I have a script to reload automations after a restart?

I have the exact same problem just starting yesterday.

Restart hass throug the UI and on boot I go to states and there are no automations showing, I go to config/reload automations and like magic they all appear again.

Not sure what the underlying issue is but if someone could help me out with a script to reload all automations on boot that would be a perfect work around for me.


I ended up installing HA again. Problem solved until today

did the reinstall fix it. I am having the same issue.

I haven’t tried since I’m not particularly keen on doing a whole re install. I’ve just got things working in a way that I’m happy with haha

same problem here…

I fixed the issue by deleting the home_assistant_v2.db file and rebooting.

Make sure you back your system up first but the db just regenerates itself. My automations are all visible right after boot now.

I have this same problem. I suspect that my input_boolean automations have something to do with it, because when I disable all of them, it works again. But I can’t find what’s really wrong with them though.

did you try my suggestion above? works perfect for me now

That fixed it for me too. Thanks Frank!