Autostart and authentication on Pi3


I’m new to this and seem be falling – badly at the first hurdles, not the first - seen Trouble with Autostart using Systemd on my Raspberry Pi but wasn’t even getting as far.

OK so got it installed and running and trying to set up the auto start but can’t for some reason run “whereis hass” all I get is
"$ hass: "

Does this mean it’s not installed, if I do whereis ifconfig I get a path so the command seems OK.
I do see the page load up in the browser under localhost:8123

Then moving on to add the file to Autostart Using Systemd. Changing user to pi and leaving everything else as is (as it seems to be talking to pi users). However after pressing enter I get prompted for a password.

“We trust you have received the usual lecture from the local System Administrator.
It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for homeassistant:”

I haven’t seen any mention of this, I tried a few things (pi password I changed, blank, hass, homeassistant) nothing. What the hell is the password??

I then rebooted. But can’t start it manually. I get back to the prompt

(homeassistant_venv)homeassistant@HomeAssistant:/srv/homeassistant $

but to run
sudo systemctl --system daemon-reload
sudo systemctl restart home-assistant.service
sudo systemctl start home-assistant@pi
(from various sources)

This is all hugely frustrating and can’t be the only one struggling.

Also on a side note, clearly I’m not a python/pi pro but have successfully built a few things on pi through online guides etc. Looking at a few of the guide pages on homeassistant and I may be wrong but “homeassistant” and “hass” seem to be used interchangeably – which if it’s the case is a killer for any newbie trying to get their head round this.


same thing with me.
was doing a manual install and now I got those same phrases and homeassistant password
I just used 2 different passwords on this image and none works.

I have the same issue. I know my passwords. Still doesn’t work. I have tried multiple times with different passwords. I have no clue.

try to connect and save your configuration files.
after this, just download and install a fresh start. it worked for me :slight_smile:

Having read some other post - it seems that you dont need the password. It’s designed this way. And I got it working without it.

in the meanwhile, I got some other readings (HA Docs) and I-m now updating more stabilized manner.
thank you for the headsup