AVAHI Deamon not recognized


trying to setup a hardware box for Home assistant, Debian 10 installed but when i try to run the supervised installer it says that AVAHI must be installed, but i installed it already, it keeps reporting back that it doesnt recognize the command.

i see that the service is started, but when i enter avahi-deamon it tels me the command is not found.

The issue is commonly with su, try to start the script with sudo (you probably need to add your username to the sudoers file).

i tried running it with sudo but i get the same error message.
when i try to run sudo avahi-daemon i get that the daemon is already running.

joost@hassio:~$ curl -sL https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh | bash -s
[Warning] If you want more control over your own system, run
[Warning] Home Assistant as a VM or run Home Assistant Core
[Warning] via a Docker container.
[Error] Please install avahi first

try sudo -i, hit enter, then do the curl command to start the script

1 Like

That worked, thank you!