AVM Fritz! Box LogIn broken?

Hi all,

after the latest update 2022.4 my AVM Fritz!Box integration(s) tell me, that there is a problem with my login “Authorization failure” and presents me with a maks to put in my username and password.

This Integration was running fine for almost a year now (with both my Fritz!Boxes) and now i can not log into them because i’m getting the error “Authozation failure”. :frowning:

I double checked and can login directly into both boxes with my (unchanged) credentials, all works fine.
The same credentials in HA are giving me the error.
I even added a new user in one of the boxes - same error in HA.
To delete the integration and set it up as a new one is (in my opinion) a bad thing, as i’m using quite a lot entitites from both boxes in automations and so on, and i’m scared that, if i set the integration up as new, all entites getting the xxx_2 and i have a lot of useless garbage entitites and all the same as new ones (with the trailing _2)…

Any help or idea is appreciated.

Don’t bother deleting the integration, I’ve tried that yesterday. It worked for about 10 minutes and then the same thing happened again.
In case anyone with more knowledge than me looks at this, this is the corresponding log output:

Logger: homeassistant.config_entries
Source: components/upnp/device.py:43
First occurred: April 7, 2022, 4:59:50 PM (1 occurrences)
Last logged: April 7, 2022, 4:59:50 PM

Error setting up entry FRITZ!Box 6591 Cable (lgi) for upnp
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 335, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/src/homeassistant/homeassistant/components/upnp/__init__.py", line 128, in async_setup_entry
    device = await Device.async_create_device(hass, location)
  File "/usr/src/homeassistant/homeassistant/components/upnp/device.py", line 60, in async_create_device
    upnp_device = await async_create_upnp_device(hass, ssdp_location)
  File "/usr/src/homeassistant/homeassistant/components/upnp/device.py", line 43, in async_create_upnp_device
    return await factory.async_create_device(ssdp_location)
  File "/usr/local/lib/python3.9/site-packages/async_upnp_client/client_factory.py", line 72, in async_create_device
    root_el = await self._async_get(description_url)
  File "/usr/local/lib/python3.9/site-packages/async_upnp_client/client_factory.py", line 395, in _async_get
    raise UpnpResponseError(status=status_code, headers=response_headers)
async_upnp_client.exceptions.UpnpResponseError: Did not receive HTTP 200 but 400

EDIT: Maybe this has something to do with it: https://github.com/home-assistant/core/pull/69455
If you read the note it says: This will solve the issue while updating from <=2022.3.x to 2022.4.1, but unfortunately not for updating from 2022.4.0 to 2022.4.1. In this case you need to re-add the fritzbox integration

I’m updating to 2022.4.1 right now, will report back in a few

EDIT2: Seems to work after upgrading! Great work by the devs

Good for you!
In my cas, i came from 2022.3.8 → working. Going to 2022.4.0 → not working → hopefully updating to 2022.4.1. → still not possible to login.
Now i’ve gone back to 2022.3.8 via an backup → it works again.

I’ll give 2022.3.8 → directly to 2022.4.1 a try.
Report back as well. :slight_smile:

EDIT: It works perfectly if you skip 2022.4.0 :slight_smile:
So you have to go from 2022.3.8 (or 3.x) to 2022.4.1 without a detour.
Thanks @RotasOpera for pointing in the right direction.

1 Like

I can confirm what cpo wrote:
2022.3.8 → 2022.4.0 → failed Fritz!SmartHome → 2022.4.1 → still failing to logon
backup to 2022.3.8 → 2022.4.1 → works!

1 Like