AVM FRITZ!Box Tools add only one device

I removed AVM FRITZ!Box Tools integration and readded it.
Now only one device is automatically added and this is the FRITZ!Box itself. All other connected devices are now shown.

The option " Enable new added entities" is active and there is no error in the log.
Do I miss something?

if you are already on 2022.2 then this change might caused your problem

you need to enable each of the devices

1 Like

Yes most probably. But where can I enable specific device tracker entities :frowning_face:

you should find the deactivated entities in the entity overview under Devices

sorry don’t know how it is named in Englisch

No problem I’m from Switzerland :slight_smile:
No I think it’s another problem after all because I have only one device. Other connected devices don’t show up as device:

grafik

I have a similar problem, maybe caused by the same reason.

I updated to 2022.2 and the device tracker isn’t working. Some devices, which were actually not connected, are not shown.

For the devices which are connected is the device tracker not working.

Device-tracking worked fine until I did the update.

I am considering loading the backup.

anything in the logs?
for my it is still working

I got the same issue, after the 2022.2 update, device tracker isn’t working.
I have restored the previous version.

Seems there is already a defect open for this

Thanks. Should be fixed with 2022.2.1 which should be released during the next few days.

Hi folks,

I’d like to add my comment to this thread.
I have allready 2022.2.1 installed with no positive effect to my device_trackers

So I deleted the whole Fritz!Box integration and installed it new.

Now there ar only four of about 180 devices available.
No hidden device entity.

WTF?

Same for me. 2022.2.1 didn’t fix it. I still have only 1 device added.

Have you already installed the latest version? If so, is everything working again?

Still not fixed with version 2022.2.3.
Same with 2022.2.5.

Thanks for your reply. So I will wait.

Any updates here? I have installed 2022.2.8 but the issue is still there :frowning:

Same for me. But I think this will fix the problem soon: https://github.com/home-assistant/core/issues/66402#issuecomment-1046257231

Fixed with 2022.3.0 and activating “Enable old discovery method” in GUI.