AVM FRITZ!SmartHome - invalid session id - switch/entities not available


I’m using the Fritz!SmartHome integration for quite some time and without a problem until now.

When I updated to version 2021.8.4 (from 2021.7.4) my DECT200 device will always disconnect over night.

In my fritzbox I’ve created a special user for HA to use my devices.

Here is what I did:

  1. Restarted HA → worked for one day, then fails over night
  2. Deleted the integration and installed it again → fails over night again
  3. Checked the HA-logs:
    Logger: homeassistant.components.fritzbox
    Source: helpers/update_coordinator.py:193
    Integration: AVM FRITZ!SmartHome (documentation, issues)
    First occurred: August 12, 2021, 3:30:38 AM (4 occurrences)
    Last logged: 3:27:24 AM
    ** Timeout fetching 653015ee1e9a2bcbbe24ebf22ddc2ea2 data*
    ** Timeout fetching 799cb4b2aabef8cb23a42b40be4280ad data*
  4. Checked my fritzbox-logs:
    Login to the user interface from the IP address [IP address] failed (incorrect session ID). To ensure security all valid sessions to IP address [IP address] will be ended.

So somehow the integration fails to use a new/correct session id and the router ends the connection.

When I use the integration-“Reload” it is working again, but again fails over night :pensive:

Hoping for some help, my coffee machine is not switching on in the moring (this is an emergency :sweat_smile:)



The same here


After vacation I gave this another try and I found the solution :grinning:

The integration AVM!SmartHome seems to work only when using the standard/automatically created fritz-user.
This user has been introduced from FritzOS 7.25 on. It usually looks like “fritz1234”.

It is used for the standard Fritzbox login without a username and only using a password (like it has always been in the past).

Unfortunately I did not have this “standard”-user in my configuration, because I had my own users created :unamused:
So I simply tried a user called “fritz0503” and it was “accepted” as automatically generated user.

Then I reinstalled the integration and used this newly created user. Now the entities are still there the next morning…yeah coffee again finally :sunglasses: :coffee:

I started using HA about a year ago and never had this AVM Smarthome problem until maybe a week ago. My problem is I deleted the standard fritz-user. Is there a way to recover it maybe? Or any other solution to solve this issue?

Edit: I missed the chapter about creating a new fritz user when reading it on my phone. I’m going to give it a try and will report later.

Just to give some feedback: I did what was described here and eve since everything is running fine :+1:

1 Like