Avoid address reservation

Hello, I’m setting up hassio on a public network with no access to the router. As a result, I can’t use address reservation for my devices. How can I keep the devices’ IP address automatically up-to-date on the configuration.yaml file? I know the Mac addresses if that helps. Thanks!

Give the devices static ips in the devices themselves

Or use their host name, not up address.

Thank you for the quick response! I don’t think the iot devices allow to configure static ip for themselves… so host name will work in the config.yaml? For example for broadlink integration or yeelight?

Yes both DNS and mDNS should work.

Got error
'Invalid config for [switch.broadlink]: not a valid value for dictionary value @ data[‘host’]. Got ‘RM3-XX-XX-XX<x’. (See ?, line ?). ’
any idea how to fix?

i have on my configuration yaml the following:


  • platform: broadlink
    host: ‘RM3-XX-XX-XX<x’
    mac: ‘XX:XX:XX:XX:XX:XX’

I don’t think < is valid in a hostname.

Can you ping RM3-XX-XX-XX<x?


Valid characters for hostnames are ASCII(7) letters from a to z , the digits from 0 to 9 , and the hyphen (-). A hostname may not start with a hyphen.


you are right… is it possible that the device has no hostname (broadlink remote control/yeelight lamp)? at least it doesn’t show up when scanning the network. the router shows ’ RM3-XX-XX-XX<x’ as host name btw. anyway any other option to avoid using ip in the configuration.yaml?

so… any idea?