Avoid automatic log-out

Hi everybody,
I have a tablet hanging on the wall showing a tileboard screen and it is 24/7 on. Every few hours it automatically logs out. I noticed that I can create long-lived access tokens, but I don’t really know how to use them. Is this the right path? Could you address me to some documentation?

thank you!

1 Like

I cannot see your tablet & settings from here. What additional information might be useful for us?

What have you already tried?
What OS is on the tablet?
How is it accessing Home Assistant?
What are your auth_provider configuration settings?

So many questions and zero information.

Sorry about the lack of information, I can understand the frustration.

  • Not much to be honest, I had just researched
  • Windows 10 (old cheap tablet)
  • Accessing Home Assistant through running chrome
  • Default settings

Are the energy setting perhaps disabling Wi-Fi after a while?
I assume you keep it plugged in to power?
I think windows 10 default settings are to disable the network after a certain time of inactivity.

What have you tried already?

I don’t think it is a matter of energy saving… I have already checked all the options and there is nothing that needs to be changed. The screen doesn’t even turn off, it is constantly on 24/7.

Perhaps the trusted network authentication will work for you.

1 Like

Outstanding! Thank you very much for helping.

1 Like

@anon34565116, unfortunately it did not fix the issue :frowning:
The tablet keeps logging out anyway and at login won’t ask for the password but still it is logged out.
Do you have any clue of what could it be? I’m using a very basic google chrome, cookies are enabled. Could it be the authentication token that expires because no page is being loaded for a long time?

Logging out of what? The tablet itself or Home Assistant? I have a couple of machines that stay logged into Home Assistant 24/7 and they never get logged out. If you are referring to the tablet, there is nothing in Home Assistant that can be done to prevent Windows from logging out. That’s a Windows setting.

Actually, I think there is a Windows setting to automatically login to an account on boot-up

which has nothing to do with Home Assistant and is a Windows setting…

Sorry guys, I should have specified that it logs out of home assistant. It has nothing to do with windows logon.
Having used trusted network auth provider makes sure that hass doesn’t ask for the password anymore, but still the browser logs out of hass every few hours.
The tablet is constantly unlocked with chrome full screen.

This is not the default behavior and not a setting on Home Assistant.

I keep at least one machine connected for weeks on end to the page. It doesn’t need to “refresh” because it is live data and doesn’t require a refresh, so that’s not what is killing the connection. Do you have extensions installed on Chrome? Do you have it deleting cookies frequently?

It is just astandard default settings chrome installation.
Actually, as I log in i normally show TileBoard on the tablet. Could this be the reason?



Yes, that could very well be the reason. I use standard Home Assistant and it never logs me out.

I’ll try to log in on normal hass on one tab and on tileboard in the other…

Different tabs share web sessions though. It would be better to use 2 different browsers rather than tabs.

But i want it to be the same session no? So that the tab with lovelace keeps the session alive also for tileboard