AWTRIX Light - Mega Weather + Sunrise + Moonrise

So for example good logs look like this:

And bad logs look ilke this:

( changed my weather provider here)

You may need to reload automations to get the logs to display

1 Like

hey :wave:t2: jeeftor. I love your Blueprint :wink:

Hi, I am desperately trying to get this running but I’m stuck with the moon rise/set part. I do have an api key and lat + lon, but don’t understand where to put that completed snippet.
I wouldn’t really need that function (nice to have though) but without that sensor I cannot use your blueprint at all (saving results in error due to missing moon config part).
Thanks in advance for your help. Kind of new to home assistant and probably don’t understand the whole yaml thing…

Hi! I have a little problem to make it work. I have missed the “feel like” variable I should have “temperature”. Now it works :ok_hand:t2:

One thing, is it possible to remove the dots under temperature …


Probably set forecast hours to 0?

I pushed a new version out if you update to awtrix .84 it will fix the colors and u fortunately break them for anything less than 84

I posted a GitHub issue, but it seems to me that this might be a better place for this question.

I’m installing this blueprint, and I get the following error in the log file:

2023-09-16 08:29:30.149 ERROR (MainThread) [homeassistant.components.automation.awtrix_weather] Error rendering variables: UndefinedError: homeassistant.helpers.template.Wrapper object has no element 8

Come over here → better support :slight_smile:

Don’t we need an invitation for Discord?

Thanks for all your good work!!!

No it’s just the awtrix discord server. Can’t really help on weekends. Ping me on Monday? :slight_smile:

Hi Jeef.

the automation fails to run due to the following error:

"ERROR (MainThread) [homeassistant.components.automation.awtrix_weather] Error rendering variables: ValueError: Template error: round got invalid input 'unknown' when rendering template '{{states(current_temp_var) | round(temp_digits)}}' but no default was specified"

I tried to change the value for “Temp digits” (multiple values, like none, “0”, “1”) but to no success.

Any hints where to check/edit/overwrite some YAML statement? (Home Assistant 2023.9.3)

Kind regards,


P.S.: I tried Discord link, but that didn’t work in my dicord (no permission?).

Thanks for this blueprint everything is working fine.
I only changed one thing in the blueprint because I didnt like that the mqtt payload was getting send every 5 seconds causing too much traffic. The weather doesnt change so frequent to justify such high mqtt traffic. Thats why I removed the time condition and replaced it with a condition that the payload is send also when the device comes online from a shutdown.

Although everything seems fine sometimes the awtrix app shows a red bar on all screen edges instead of showing the forecast progress bar (as shown in the picture).

Can someone explain why this is happening?

This is what should be shown:

Ok I figured it out. I had to remove the lifetime keys inside the json payload. Now its working without the high mqtt traffic.

If I wasn’t on vacation now I’d make that configurable. :slight_smile:

I’m guessing you’re asking for the wrong field in your forecast. Or current temp. Basically a sensor isn’t there.

I really wish the blueprints had better error handling…. For templates

hi just want to ask does anyone know how to install AWTRIX Flows

lets you download a yaml file but where does this go? to make flow work

any help would be great thanks

1 Like

@jeeftor how often does it update or show the weather etc? or do i have to do it myself from HA?

It’s something maybe stupid like once a min. I’m traveling but can tweak if needed

oh right, where can I tweak it?

so everything works well however during the day I cannot see any icons, the moon icons do show but not the other ones. I did call your scrip and I get options on which directory I want to download your icons in. I select “1” which is the “dev” directory as all the others are icon specific directory. see below please: