AWTRIX Light - Mega Weather + Sunrise + Moonrise

NOTE: Make sure you are using Awtrix .84 or higher firmware

GO TO THE AWTRIX DISCORD FOR SUPPORT: Channel

Hi folks, I’ve published a blueprint for AWTRIX Lite for what I call the MEGA Weather App.

Open your Home Assistant instance and show the blueprint import dialog with a specific blueprint pre-filled.

Easiest way to get the blueprint is from: AWTRIX Flows

sunset
weather

awtrix-2

Some of the features include:

  • Hourly Temp Prediction bar across the bottom
  • Moon Imagery (showing the various statuses)

Fully customizable icons

Sunrise/set times etc.

4 Likes

I’m trying to figure out how to install the blueprint, and I’m completely stumped here. There seems to be no manual way to install it from clipboard or the file on the awtrix flows site.

Home assistant wants a community URL to install from, but this post isn’t formatted properly for that.

Am I missing something obvious here?

1 Like

You can get the code from the awtrix flow http://flows.blueforcer.de → but I really should add a blueprint link above and will put it on my overlong todo list

You were → but look at this post once again :slight_smile:

1 Like

Hi! Thanks for creating and sharing the blueprint.

I’ve set it up with everything required (openwheather, moon sensor, ipgeolocation), however it never gets triggered. Even if I Run it explicitly.

Any idea why?

I set it up yesterday and it works perfectly for me, did you check if there are errors in the execution history ?

There are no errors and there is no execution history because automation was never triggered.

I’m using ESP32 Dev board with Awtrix Light firmware from here: AWTRIX LIGHT

Do I need to have some specific MQTT prefix for it to work correctly?
My MQTT prefix is ‘awtrix_01’. It’s discovered by HA and works fine.

Home Assistant 2023.5.4
Supervisor 2023.06.2
Operating System 10.3
Frontend 20230503.3 - latest

I don’t think so, i just had to select my device when creating the automation from the blueprint. I really don’t know why it doesn’t even get triggered for you, it is supposed to run every 5 seconds

Are you using Ulanzi tc001 with Awtrix Light?

Hey guys. I’ll be around Monday to help troubleshoot any issues y’all having. Weekends are family time

2 Likes

Yes, i just received it and started playing around with custom apps and home assistant. Are you able to send a test notification to the device with the MQTT integration ?

Yes, MQTT notifications work.

I’ve found another weather app Link to Blueprints: Start import – My Home Assistant that requires MQTT Basetopic and it does work with my setup.

It’s possible that this weather app requires some specific MQTT prefix for it to work correctly with non-Ulanzi devices.

Got it to work! :slight_smile: As expected - my mistake. :slight_smile:
The problem was - I did not remove brackets <> when added REST sensor for moon rise/set times and API key.

resource: https://api.ipgeolocation.io/astronomy?lat=<LAT>&long=-<LON>&apiKey=<API_KEY>

Thanks for help and great App.

2 Likes

I’d setup the automation as described. All needed sensors are working. I’ve uploaded the icons to the clock but I get that error:

Logger: homeassistant.components.automation.virtual_awtrix_weather
Source: /usr/src/homeassistant/homeassistant/components/automation/__init__.py:608
Integration: Automatisierung (documentation, issues)
First occurred: 11:25:50 (2 occurrences)
Last logged: 11:25:50

Error rendering variables: UndefinedError: homeassistant.helpers.template.Wrapper object has no element 9

here is my configuration. maybe it helps:

- id: '1690362936986'
  alias: '[VIRTUAL] AWTRIX Weather'
  description: ''
  use_blueprint:
    path: jeeftor/awtrix_weatherflow.yaml
    input:
      awtrix:
      - 1d1160a501d3430ffb54b852be14184e
      forecast_var: weather.dwd_weather_mycity
      forecast_temp_field: temperature
      temp_digits: 1
      temp_suffix: °C
      current_temp_var: sensor.temperature_mycity
      moon: sensor.moon_phase
      moon_rise_set: sensor.ip_geo_location
      sun_time_format: '%H:%M'
1 Like

Best to jump on the awtrix light discord for help :slight_smile:

Oh, I am totally in. I have several “apps” and notifications for it. I just provide some blueprints, too. And I am happy when people gave me feedback in order tobimprove the blueprint or its documentation.

hi guys i cant seem to get this to work ive done every thing it says to do but the automation say never run

tried to run it nothing happens the api is working have i missed somthing?

What does your trace output look like and your logs

trace says Stopped because of unknown reason “null” at 14 August 2023 at 03:37:20 (runtime: 0.02 seconds) nothing in logs

Ther should be something in the logs if trace is failing because it will say there is a template error or something. I’d suggest awtrix light discord for more help.

If you hit save it should try to repress the automation and will drop something in the logs