Axis camera sensors disappeared

A while ago I notices my Axis camera motion sensors stopped working.
In Axis I had configured 3 zones in view and for each a separate motion sensor was available.
Based on these I have automations to ring a doorbell when someones at the door, and take a picture, and check whether we have mail.
But for a while, these sensors have been unavailable.

Tonight, I have tried re-installing the integration, but now only 1 entity (the camera) is added. I have tried users with several access rights (viewer, operator, admin). All have the same result.
Then I upgraded to HA 2021.5.1, but problem still exists.
And after I upgraded I thought, mmm … maybe this started when I upgrade to 2021.4.x. I have looked in the release notes, but nothing for Axis was mentioned.

Anyone have the same problem?
Anyone knows how to solve this? Can the motion sensors be added manually?
Or is it a problem in the integration since 2021.4.x ?


There was a fix to better handle web requests not timing out with slow devices on 2021.4

Try downgrading to earlier releases to see if you notice any difference. Did you by chance upgrade fw of the device recently? Or you introduced a custom component? A lot of different things could be the cause of this

I did not upgrade the Axis camera for a long time. Latest firmware is more 2 years old I think.
I have thought about downgrading Home Assistant, but that is not that easy I fear since both 2021.4 en 2021.5 have performed a db migration.

Try setting up a second instance of ha to test different versions. Keep your cameras up to date it’s important for many reasons :slight_smile:

I found the issue.
I first had the HA instance on an isolated VLAN, but since this was cumbersome with integrating with devices (each one required a firewall change). Therefore I moved it to the LAN from which it can freely access all devices both on the LAN and VLAN.

However, apparently for the Axis sensors to work, a separate connection from the Axis camera to the HA instance is required. After creating a firewall rule allowing access from the Axis camera to the HA instance, and reloading the integration, the input sensors and camera profile entities came back.

Does anyone know what kind of connection this is and how it works? Is it Http push notifications?

1 Like

It’s an rtsp connection. If youre devices run newer firmwares mqtt is also supported

I have almost similar problem.
My Axis camera motion sensors worked for few months, but now they are just not triggering anymore (always stays “clear” status). But camera stream is fine.
No errors, just not triggering in HA. I tried to delete integration and re-install it. Motion sensors are added, but not working.
I have installed new HA to another computer for a test and it’s just works, no problems at all.
I thought what could it be. All i remember, i connected Home Assistant Cloud(Nabu Casa) few days ago. But i also added cloud on second HA(test), and there is no problems with axis motion sensors.

What else i can try? Please help.


Create an issue on github and share debug logs. That’s the first step to understand what happens :). Make sure you don’t have any firewalls blocking rtsp traffic

I found solution for me. If i rename device to any new name, motion sensor works!
If i rename it back to old name, motion sensors stops triggering.
I tried to look old name in core.config_entries and core.device_registry, not found.
Looks like some bad settings stuck somewhere with old name.

Nope. After some time motion sensor stopped working again.
I removed and re-added axis device many times, it’s working for 1-120minutes and stop reporting any motion.
I re-installed HA and restored from backup. Same problem.
On the same time, video stream works fine.
I don’t think it’s connected in any way with firewall. I don’t even have firewall in my internal network.

Same Axis device work fine with other HA instance for weeks.

Could it be time related? Do you have a time server set up properly?

Funny, ran into the same issue and found my question from 2021.
Totally forgotten, but … my own answer solved the issue again for me. Thank you, past-me :wink:

Recently I switched from HA in a docker container to running HA OS on Proxmox and therefore the IP of HA has changed. Updating my firewall settings to allow Axis to connect to HA solved the issue again.

Still don’t know why this is needed.
Cannot be a RTSP thing since that’s always pull based and video does work, only the other integration properties did not.

1 Like