AZ Delivery D1 mini don't connect to my wifi

Dears,

I use a D1 mini Az Delivery. Is a ESP8266EX processor. Y tested the following simple program:

esphome:
  name: hola

esp8266:
  board: d1_mini

# Enable logging
logger:

# Enable Home Assistant API
api:
  encryption:
    key: "NMlToN8yk3bdiTNq0JXFsSvo7YmrrPURFl7U7q2k6ig="

ota:
  password: "d500f3a1dd33703ab22315405d6707ef"

wifi:
  ssid: "Orange-0A46"
  password: "xxxxxxx"

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "1212 Fallback Hotspot"
    password: "Rg2sjJ7VRgbi"

captive_portal:

The ESPHome validate the program without problem. I upload the program to the esp and the logs shows that can’t find my network, but find other networks in the neighborhood. I have another ESP and I use the same exact part of code:

wifi:
  ssid: 'Orange-0A46'
  password: 'XXXXXX'

And in the others esp they don’t have any problem to connect to my wifi router…

The logs shows:

[11:53:44][I][logger:243]: Log initialized
[11:53:44][C][ota:461]: There have been 6 suspected unsuccessful boot attempts.
[11:53:44][I][app:029]: Running through setup()...
[11:53:44][C][wifi:037]: Setting up WiFi...
[11:53:44][D][wifi:373]: Starting scan...
[11:53:50][D][wifi:388]: Found networks:
[11:53:50][D][wifi:390]:   No network found!
[11:53:55][D][wifi:373]: Starting scan...
[11:54:01][D][wifi:388]: Found networks:
[11:54:01][D][wifi:436]: - 'MOVISTAR_91E0' (C8:B4:22:36:91:EF) ▂▄▆█
[11:54:01][W][wifi:442]: No matching network found!
[11:54:06][D][wifi:373]: Starting scan...
[11:54:11][D][wifi:388]: Found networks:
[11:54:11][D][wifi:390]:   No network found!
[11:54:16][D][wifi:373]: Starting scan...
[11:54:22][D][wifi:388]: Found networks:
[11:54:22][D][wifi:390]:   No network found!
[11:54:27][D][wifi:373]: Starting scan...
[11:54:33][D][wifi:388]: Found networks:
[11:54:33][D][wifi:436]: - 'MIWIFI_2G_aCPq' (24:D3:F2:C0:86:5E) ▂▄▆█
[11:54:33][W][wifi:442]: No matching network found!
[11:54:38][D][wifi:373]: Starting scan...
[11:54:44][I][wifi:136]: Starting fallback AP!
[11:54:44][C][wifi:201]: Setting up AP...
[11:54:44][C][wifi:203]:   AP SSID: '1212 Fallback Hotspot'
[11:54:44][C][wifi:204]:   AP Password: 'Rg2sjJ7VRgbi'
[11:54:44][C][wifi:213]:   IP Address: 192.168.4.1
[11:54:45][D][wifi:388]: Found networks:
[11:54:45][D][wifi:436]: - 'MOVISTAR_91E0' (C8:B4:22:36:91:EF) ▂▄▆█
[11:54:45][W][wifi:442]: No matching network found!
[11:54:50][D][wifi:373]: Starting scan...
[11:54:56][D][wifi:388]: Found networks:
[11:54:56][D][wifi:390]:   No network found!
[11:55:01][D][wifi:373]: Starting scan...
[11:55:07][D][wifi:388]: Found networks:
[11:55:07][D][wifi:436]: - 'vodafoneA9B8' (78:94:B4:C9:A9:B9) ▂▄▆█
[11:55:07][W][wifi:442]: No matching network found!
[11:55:12][D][wifi:373]: Starting scan...
[11:55:18][D][wifi:388]: Found networks:
[11:55:18][D][wifi:390]:   No network found!
[11:55:23][D][wifi:373]: Starting scan...
[11:55:29][D][wifi:388]: Found networks:
[11:55:29][D][wifi:390]:   No network found!
[11:55:34][D][wifi:373]: Starting scan...
[11:55:40][D][wifi:388]: Found networks:
[11:55:40][D][wifi:436]: - 'vodafoneA9B8' (78:94:B4:C9:A9:B9) ▂▄▆█
[11:55:40][W][wifi:442]: No matching network found!
[11:55:45][D][wifi:373]: Starting scan...
[11:55:51][D][wifi:388]: Found networks:
[11:55:51][D][wifi:436]: - 'MIWIFI_2G_aCPq' (24:D3:F2:C0:86:5E) ▂▄▆█
[11:55:51][W][wifi:442]: No matching network found!
[11:55:56][D][wifi:373]: Starting scan...
[11:56:02][D][wifi:388]: Found networks:
[11:56:02][D][wifi:436]: - 'MOVISTAR_1A68' (84:AA:9C:80:1A:69) ▂▄▆█
[11:56:02][W][wifi:442]: No matching network found!
[11:56:07][D][wifi:373]: Starting scan...
[11:56:12][D][wifi:388]: Found networks:
[11:56:12][D][wifi:390]:   No network found!
[11:56:17][D][wifi:373]: Starting scan...
[11:56:23][D][wifi:388]: Found networks:
[11:56:23][D][wifi:390]:   No network found!
[11:56:28][D][wifi:373]: Starting scan...
[11:56:34][D][wifi:388]: Found networks:
[11:56:34][D][wifi:436]: - 'MOVISTAR_91E0' (C8:B4:22:36:91:EF) ▂▄▆█
[11:56:34][D][wifi:436]: - 'vodafoneA9B8' (78:94:B4:C9:A9:B9) ▂▄▆█
[11:56:34][W][wifi:442]: No matching network found!
[11:56:39][D][wifi:373]: Starting scan...
[11:56:45][D][wifi:388]: Found networks:
[11:56:45][D][wifi:390]:   No network found!
[11:56:50][D][wifi:373]: Starting scan...
[11:56:56][D][wifi:388]: Found networks:
[11:56:56][D][wifi:436]: - 'MOVISTAR_91E0' (C8:B4:22:36:91:EF) ▂▄▆█
[11:56:56][W][wifi:442]: No matching network found!
[11:57:01][D][wifi:373]: Starting scan...
[11:57:07][D][wifi:388]: Found networks:
[11:57:07][D][wifi:436]: - 'MOVISTAR_91E0' (C8:B4:22:36:91:EF) ▂▄▆█
[11:57:07][W][wifi:442]: No matching network found!
[11:57:12][D][wifi:373]: Starting scan...
[11:57:18][D][wifi:388]: Found networks:
[11:57:18][D][wifi:390]:   No network found!
[11:57:23][D][wifi:373]: Starting scan...
[11:57:29][D][wifi:388]: Found networks:
[11:57:29][D][wifi:390]:   No network found!
[11:57:34][D][wifi:373]: Starting scan...
[11:57:40][D][wifi:388]: Found networks:
[11:57:40][D][wifi:390]:   No network found!
[11:57:45][D][wifi:373]: Starting scan...
[11:57:51][D][wifi:388]: Found networks:
[11:57:51][D][wifi:436]: - 'vodafoneA9B8' (78:94:B4:C9:A9:B9) ▂▄▆█
[11:57:51][W][wifi:442]: No matching network found!
[11:57:56][D][wifi:373]: Starting scan...
[11:58:02][D][wifi:388]: Found networks:
[11:58:02][D][wifi:436]: - 'MIWIFI_2G_jgCz' (24:D3:F2:C6:22:FB) ▂▄▆█
[11:58:02][W][wifi:442]: No matching network found!
[11:58:07][D][wifi:373]: Starting scan...
[11:58:13][D][wifi:388]: Found networks:
[11:58:13][D][wifi:436]: - 'vodafoneA9B8' (78:94:B4:C9:A9:B9) ▂▄▆█
[11:58:13][W][wifi:442]: No matching network found!
[11:58:18][D][wifi:373]: Starting scan...
[11:58:24][D][wifi:388]: Found networks:
[11:58:24][D][wifi:390]:   No network found!
[11:58:29][D][wifi:373]: Starting scan...
[11:58:35][D][wifi:388]: Found networks:
[11:58:35][D][wifi:390]:   No network found!
[11:58:40][D][wifi:373]: Starting scan...
[11:58:46][D][wifi:388]: Found networks:
[11:58:46][D][wifi:390]:   No network found!
[11:58:51][D][wifi:373]: Starting scan...
[11:58:57][D][wifi:388]: Found networks:
[11:58:57][D][wifi:390]:   No network found!
[11:59:02][D][wifi:373]: Starting scan...
[11:59:08][D][wifi:388]: Found networks:
[11:59:08][D][wifi:390]:   No network found!
[11:59:13][D][wifi:373]: Starting scan...
[11:59:18][D][wifi:388]: Found networks:
[11:59:18][D][wifi:390]:   No network found!
[11:59:23][D][wifi:373]: Starting scan...
[11:59:29][D][wifi:388]: Found networks:
[11:59:29][D][wifi:436]: - 'MOVISTAR_1A68' (84:AA:9C:80:1A:69) ▂▄▆█
[11:59:29][W][wifi:442]: No matching network found!
[11:59:34][D][wifi:373]: Starting scan...
[11:59:40][D][wifi:388]: Found networks:
[11:59:40][D][wifi:390]:   No network found!
[11:59:45][D][wifi:373]: Starting scan...
[11:59:51][D][wifi:388]: Found networks:
[11:59:51][D][wifi:390]:   No network found!
[11:59:56][D][wifi:373]: Starting scan...
[12:00:02][D][wifi:388]: Found networks:
[12:00:02][D][wifi:436]: - 'MOVISTAR_91E0' (C8:B4:22:36:91:EF) ▂▄▆█
[12:00:02][D][wifi:436]: - 'vodafoneA9B8' (78:94:B4:C9:A9:B9) ▂▄▆█
[12:00:02][W][wifi:442]: No matching network found!
[12:00:07][D][wifi:373]: Starting scan...
[12:00:13][D][wifi:388]: Found networks:
[12:00:13][D][wifi:436]: - 'MIWIFI_2G_aCPq' (24:D3:F2:C0:86:5E) ▂▄▆█
[12:00:13][W][wifi:442]: No matching network found!
[12:00:18][D][wifi:373]: Starting scan...
[12:00:24][D][wifi:388]: Found networks:
[12:00:24][D][wifi:390]:   No network found!
[12:00:29][D][wifi:373]: Starting scan...

Can someone understand what could be happening?

Thanks in advance,

Jose

Are you sure your wifi is well in 2.4 too ? and not only 5Ghz ? Also considering all Wifi signals you get around I would strongly check your 2.4 Wifi signal is on a not too busy channel if possible :slight_smile:
What distance too between your Wifi router and your ESP ? If you use Wifi of your internet box expect quite lot of problems of stability/connection…

Dear vincen,

Thanks for your reply.

I tried with others channels, and not difference. I tried now, with another D1 mini, same model and brand, and with this new D1 the logs say:

[W][wifi_esp8266:482]: Event: Disconnected ssid='Orange-0A46' bssid=[redacted] reason='Auth Expired'
[W][wifi:536]: Error while connecting to network.
[W][wifi:572]: Restarting WiFi adapter...
[I][wifi:248]: WiFi Connecting to 'Orange-0A46'...
[W][wifi_esp8266:479]: Event: Disconnected ssid='Orange-0A46' reason='Probe Request Unsuccessful'
[W][wifi:536]: Error while connecting to network.
[W][wifi:572]: Restarting WiFi adapter...
[D][wifi:373]: Starting scan...
[D][wifi:388]: Found networks:
[D][wifi:436]: - [redacted] [redacted]▂▄▆█
[D][wifi:436]: - [redacted] [redacted]▂▄▆█
[D][wifi:436]: - [redacted] [redacted]▂▄▆█
[W][wifi:442]: No matching network found!
[D][wifi:373]: Starting scan...

The AP is only 2 meters away from the D1 mini…

move your D1 away of AP ! your AP is using only standard Wifi encryption ? as the logs look to indicate identification problem :confused: