Backups broken after connecting to a NAS

Hey All,
Super excited to see the new ability to connect to a NAS, specifically for saving my weekly backups and potentially automating this. But . . . Here is what I did:

  1. In the Storage page, connected successfully to my NAS.
  2. Went to Backups and tried to select a different location for backups. It did list the new NAS location but the Save button was greyed out… Hmmmm
  3. Went back to Storage to verify settings and decided to delete the connection and create a new one with a better name.
  4. Went back to Backups and I only get the spinning wheel. Hmmm
  5. Went back to Storage and recreated the original connection.
  6. Went back to Backups and still get the spinning wheel…

Can’t even revert to the last backup…

Any ideas?

HA running on a Pi4
NAS (OpenMedia Vault) running on a Pi4.



I was having nearly the same issue. I added the NAS under storage. Then when I go to Backups (didn’t even get to selecting a new location) and I just a blank page with a spinning wheel.

I ended up closing out my browser (which clears my cache per my browser settings) and then went in again fresh with a new browser window and it was ok again. One thing that was odd is that when I THEN went to change the backup location, the NAS was already selected even though I had not previously explicitly selected it.

Not odd at all, that’s the documented behavior.