Bad gateway when trying to access Configurator

Tags: #<Tag:0x00007f73973629c0>

I have never had an issue accessing the Configurator but for some reason started getting bad gateway errors today. I restarted HA and still getting the error only when I click on configurator UI. Any ideas? I am running version 0.92.2. I haven’t upgraded in a few weeks so not sure why this is suddenly appearing.

1 Like

I’m having the same issue, but only on one of my instances of Homeassistant. I am running ver 0.96.5 on both boxes. One is a vm running hassio , the other a RPi3. It appears the addon is refusing connections on the RPi3. I have this in the log:>

ERROR (MainThread) [hassio.api.ingress] Ingress error: Cannot connect to host 172.30.33.5:8099 ssl:None [Connection refused]

The only difference I can find between the two boxes is , of course, the architecture of the addon and IPv6 is enabled on the VM. There is no IPv6 on the RPi3, which I believe explains this in the log of the addon:

nginx: [emerg] socket() [::]:8080 failed (97: Address family not supported by protocol)
2019/07/31 11:55:59 [emerg] 21#21: socket() [::]:8080 failed (97: Address family not supported by protocol)
INFO:2019-07-31 11:56:00,180:hass_configurator.configurator:Starting server
INFO:2019-07-31 11:56:00,182:hass_configurator.configurator:Listening on: http://127.0.0.1:80

The configurator works great on the VM instance of Homeassistant.
Should I enable IPv6 on the RPi3 or is there other ideas?

1 Like

I am having the exact same issue and have been pulling my hair out trying to figure out what is causing it.

19-09-12 02:39:58 ERROR (MainThread) [hassio.api.ingress] Ingress error: Cannot connect to host 172.30.33.4:8099 ssl:None [Connection refused]

Whenever I try to go into the Configurator I see the following:

502: Bad Gateway

You hit the nail on the head. I previously disabled ipv6 due to another issue when i first configured HASSIO. I went back and enabled ipv6 on my ubuntu server, rebooted, and now I see the Configurator! I havent worked with it yet, however, I have never been able to actually load the Configurator. Thanks for your post.

I finally went back and enabled IPv6 on the RPi3, ensured that ipv6 was working by issuing ‘ping6 google.com’ and tried accessing the configurator again. I can confirm that enabling IPv6 on the pi did in fact fix the issue. Maybe now I can break my WinSCP-SecureCRT habit.

I had the same issue when I installed the configurator. After checking that ip6 was enabled (it was) I just performed a reboot after which the configurator is working fine.