Badges and Error Messages


I have a badge at the top of my view and it says “Error: Entity Not Found”.

I don’t know what the badge originally was, but if I click on “Configuration” in the left hand panel and then select “Entities” and then go to the inverted triangle at the top and ensure all 3 options are ticked (eg show disabled entries) all I can see are 2 that show a red “restored” circular arrow, a few Read-only ones plus others that have nothing in the status column.

So 2 questions:

  1. How do I find out which entities is causing this “Error” badge and remove it.
  2. Where does HA get the info on what to use to create badges by default? By that I mean I haven’t gone to the badges page and done any configuration, so the ones I see have been created “Automatically”.

What confuses me about that is that it has 3 badges for one Samsung tablet (battery level, battery state and wifi connection) but I have another Samsung tablet and nothing appears there for that. Ditto for phones. It has one for my phone but not the wife or daughter’s

I would just like to tidy this up as I don’t really want badges showing the status of batteries (if they are discharging or charging) etc.

Thanks in advance.

You can just edit the Lovelace page.
3 dots at the top right > Configure UI. Edit the tab you are on with the little pencil icon and goes to the badges tab.

You can then add/remove the badges from there.

Thank you so much.

I’ve found out that the badge that read Entity not Found was sensor.mi_9t_geocoded_location

Not sure why this stopped working but other badges relating to my Mi_9T phone still worked but at least my badges are tidied up.


Edit: I’ve got so much to learn :slight_smile:

I’ve got a badge that shows my name and that I’m home. Looking into it, it shows the source as being device_tracker.sm_t720 which is my Samsung S5e.

I don’t recall doing anything when I got the tablet for it to appear let alone set it as a means of saying whether I’d be home or not. If I was going to have a device say whether I’m home or not, it would be my phone.

Edit 2: Slowly fixing things as I learn. I’ve changed the badge from device_tracker.sm_t720 to device_tracker.life360_my_name as this has my Life360 User Profile picture and still shows Home or Away.

My next step is to work out how to change the text underneath the badge so it reads My Name rather than device_tracker.life360_my_name

1 Like

Configuration in the side bar.
Customizations at the bottom.
Find the entity and change the name.

Enjoy, part of the fun is the figuring it out :slight_smile:

Yep, I’ve been here and can see all the Entities. (so far so good :slight_smile: )

This I can’t find. At the bottom of the Entities page of Configuration?? I can see the edit button at the bottom of the cards when I’m in Edit Dashboard mode.

If I go to Configuration at the side menu, then Entities and then click on say device_tracker.life360_my_name, it brings up a box saying:

This entity does not have a unique ID, therefore its settings cannot be managed from the UI.

Under the Integrations column of the Entity page, it shows ‘Mobile App’

Yes it’s a nice feeling when you finally work something out.

I’ve just worked out that Mobile App is the reason Home Assistant knows about my phone and my Samsung tablet, but doesn’t know about the wife or daughter’s phones or tablets, even though they are connected via the same Wi-Fi as it’s because I have the Home Assistant app on my phone.

At the same time, it’s daunting to see things and not sure how to proceed. eg Under Integrations I have 3 that have a “configure” option, but not sure if I should or not as I don’t know exactly what they do. 2 of them appear to ‘overlap’ as one is UPnP for UPnP/IGD: InternetGat… and the other is UPnP/IGD: FritzBox7… which obviously relate to my FritzBox 7590, but I already have an AVM FritzBox integration, so should I ignore these? The other one with the configuration option is a HomeKit controller for YeelightColorBulb-5D7E but I don’t have HomeKit so I should ignore this one and install the Yeelight one?

I’m still enjoying the journey…

http://your-ha-ip-address:8123/config/customize is what you want. (obvisously change your IP address in there)

Find the entity and change the name with the little pencil icon.

I would only add stuff you want at the moment and take things one device at a time and use the documentation to work it out. If you ignore them in the integration section, you can always un-ignore them later on or add them manually.

Ok. I used your link and got the customisation page. The weird thing is that in the left hand bar, where I normally see the option “Configuration”, with your link, it changed to “Config”. Perhaps that’s why I couldn’t see the Customization option?? See screenshot below

When I found one of the 2 entities ( device_tracker.life360_my_name) and changed the name to “Max”, I got the following message (but the name under the badge did change to “Max”):


Thanks for your help. I wonder why I couldn’t see the customization option without manually entering the address and why “Configuration” changes to “Config” when I used your address?? Weird.

Anyway, it’s working now. Thanks again

Ahhh, you don’t have the correct config. If you restart HA it won’t keep that change you made.

You need to have the this in your configuration.yaml:

  customize: !include customize.yaml

Might explain why you don’t have it in your configuration section.

1 Like

Yes, I found that out. You replied before I had a chance to mention it.

Fixed this and all working.

I really appreciate all the help. Thanks again.

1 Like

You’re welcome. Glad it is working :slight_smile:

1 Like