balenaEtcher flash to SD card fails. Newbee hits a dead end

Following the installation instructions the final step of copying to the SD card fails. I have tried with two different PCs (Windows) and also two different SD cards. Same error each time. I am using the Raspberry Pi 3 option from the install guide.

I am robotically following the process described on the HS web site so I have no way to progress.

Message “Attention, something went wrong…” doesn’t help

Also, I can’t text-copy from the error report box. Who thought that was a good idea?

I am a newbee to Raspberry Pi so please keep the jargon to a minimum.



Does the message box say anything more than ‘something went wrong’? Can you take a screen shot (in Windows) or take a photograph of your screen with your phone or simply write it down with pencil on paper?

Pardon me for asking, but which would be the ‘HS web site’?

The install guide…

The message box…

Too much to type and as I said, can’t be copied.


  1. You have a bad image - did you try downloading the image and flashing it locally?
  2. The SD card is dead - did you try a new, known good, SD card?

As I said in my post, I tried two computers and two SD cards.

I am following a lookie-see-lookie-do guide. I don’t know how to download and flash locally. Who knows what that button in the app dose.

Meaning, first download the image, and then flash it; do NOT use the web url within balena-etcher

Can you point me to a Pi 3 image? Also, by “flash” do we mean just copy the file to the SD card or is it more complicated than that to make a bootable SD card with Pi operating system and Home Assistant installed?


They said it was easy, just follow the guide. Does the guide point me to a bad file? As usual, I sit down to do a five minute job and the rest of the day disappears. Doh!

Select Raspberry Pi 3

  1. Download this file to your PC →
  2. start Balena etcher, choose flash from file (instead of flash from URL) and use the file downloaded in point 1

The rest is same same

(one of the reasons for having a incomplete image might be poor internet; downloading it first could help with getting a complete image ;))

1 Like

That worked a treat.

I am off to continue the set up.

Many thanks.

That helped me thanks @aceindy. I’d waited more than long enough for a 2.15gb file to download but the flashing failed multiple times. Obviously I didn’t wait long enough!!!

I run still into the problem that Balena fails. I have tried all suggestions: downloaded the file, disabled Windows defender, run Balena as administrator. I don’t see any error report that suggests what I need to do.

1 Like

I tried this steps you gave to the person coming for help and for whatever reason my Micro Mini does not detect it as a bootable device. Hoping for some ideas?

check bios dor uefi boot mode?

already checked it and set correctly