BalenaEtcher won't flash/authorize on Mac Catalina Beta

trying to flash a new sd card, I dl’d the latest Hassio and Etcher. On clicking the Flash! button, I need to enter my password, and then I receive a message something went wrong:


to be sure the archive isnt corrupted, Ive re-downloaded it 3 times now, no change.

tried the older Etcher App, with which I had no issues before, but then I see this first:

maybe caused by the fact I am using a later MacOs version than the version this Etcher was written for, So I clck OK and continue .

Which is then followed by an error stating I am not authorized


which is rather remarkable since I am the only admin on my Mac…

this is what Finder shows me on the sdcard:

at the bottom, it states I have adjusted admission authorization, but I wouldn’t know which or how to change that…

anyone please? thanks for having a look

btw, cant we just use disk-utility for this? select the drive, select the image and ‘zet terug’ (Restore) ?

error in the developer tools of Etcher:

replyin to myself for reference.

Checking the BalenaEtcher community hinted that they don’t yet support MacOS Catalina. Which I have installed on my MacBook. Tried every available option, formatted the card/mounted/unmounted. What have you. No succes.

Of course my older MacBook died on me, so couldn’t use that any longer (no such thing as coincidence…)
Then realized had another iMac doing nothing in one of my siblings rooms, which they never update :wink:

et voila:





so, fyi: don’t upgrade to Catalina beta yet, If you need to Etch some SD Cards…


Hey just stumbled across this pst and I am having the same problem. I found the solution here, however they have a typo… this is the command to use in terminal to get balenaEtcher to run with sudo permissions:

sudo /Applications/


This will start balenaEtcher in root and it works! thanks fo the lead!



This worked for me, thanks!

Hi there,
Really appreciate your posting for this issue! Believe you are also a Linux expert, great!

I have Catalina on my MAC and I tried this but in terminal its still asking for my password… Of which I dont have, meaning I dont have a password set anywhere on this machine.
What do I do?