Bali Blinds via Wink


I am a new Home Assistant user and am trying to get my Bali Blinds set up. I currently have a Wink Hub 2 paired to my Somfy Zwave to ZRTSI interface. It shows up in Home Assistant but only with the down arrow (the up arrow is greyed out). However, neither button actually sends commands to the blind.

Any thoughts on how to properly set this up?


Sounds like something isn’t working right. Can you share you blinds with my Wink account so I can check out the API response for the blinds?

[email protected]

Edit: I should mention that I am the Wink/Home Assistant integration dev and have found that the easiest way for me to track down problems is to try to re-create them myself. Since I don’t have all the hardware that Wink integrates with, the easiest thing to do is have the product shared with me via Wink’s built in sharing function. This allows me to access your device using my Wink account. No need to share your credentials and you have the ability to revoke the sharing at any time.

Thanks. I actually have no issue operating them from the wink app … only when trying to use it in Home Assistant. Would you still need me to share the blinds?

Yeah, sharing them allows me to load up my Wink account in Home Assistant and pull your blinds in. It is no different then how you are able to use the Wink app and Home Assistant at the same time.

Done. Let me know if you need anything else. I appreciate the help!

So the position from the API is reporting null. Can I change the position on them to see if it updates to something else?

Go for it. Thanks

Okay ran though that opened/closed it. It send 0.0 or 1.0 which the python-wink library sends 0 or 1 so maybe that is the issue? But I will have to test it out once I get home. If you adjust the position from the blinds them selves (Is that even possible?) does the Wink app show the updated position?

I have a remote for the blinds … I will try changing the position tonight when I get home and see if the wink app reflects the change. Thanks

Ok, so I tried the remote and wink is not reflecting the proper status

Gotcha, so that’s the issue I think. Can you see if HA will work if you trigger the down button when the blinds are up?

Yes, I was able to trigger the blinds down through HA with the button. The up arrow still shows greyed out and the status in the Wink app is not changing.

Do you think I should try re-pairing my Somfy ZRTSI bridge to Wink?

You could try that, but to me it sounds like the state is preserved so not sure the re-pair will work. I think in order to fix this be “fixed” the blinds are going to have to be setup to assume state in HA meaning that it won’t know the state (because Wink isn’t sending it) but both buttons will always be enabled.

Thanks again for your help. So, yes, the re-pairing did nothing to fix the problem.

I have also noticed that even when I use the wink app to say open the blinds, after about 15-20 seconds it reverts back to showing them as closed in the app.

HA still only shows the down button (which I find strange if Wink is defaulting to the closed position).

How would I go about implementing the fix you suggested? Or is that something you need to build into your component?

I can provide your a custom component to load up that should allow you to “test” this but then it will need to be officially pushed. Give me a few minutes and I will try to send you something

unzip this in your config directory and restart HA and see what happens.

1 Like

Success! Thanks so much for this. Both directions are working for me now.

Good deal, okay I’ll have to make a library update to get this working for everyone I think but I’ll let you know when it will get merged in so you can remove the custom component